<!DOCTYPE html>
<html>
<head>
	<meta http-equiv="content-type" content="text/html; charset=UTF-8">
		<title>ASU basketball&#039;s Rob Edwards named Pac-12 Player of the Week</title>
	<meta name="keywords" content="Phoenix Arizona Sports News | Phoenix Breaking Sports News, Home,Arizona Sports Now on 98.7 FM">
		<meta name="author" content="">

	<meta name="verify-v1" content="XrJiQDsWmPaoqGKN0EHKs7ult0rBB0W9zj4cWkAPRVI=" />

	<meta name="viewport" content="width=device-width, maximum-scale=1.0">
	<meta name="apple-itunes-app" content="app-id=719629934">
	<meta property="fb:pages" content="175932795758464" />



			<script type="text/javascript">
		var ajaxurl = 'http://arizonasports.com/wp-admin/admin-ajax.php';
		</script>
		
<!-- This site is optimized with the Yoast SEO plugin v9.1 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="ASU&#039;s Rob Edwards received the holiday gift of being named the Pac-12&#039;s Men&#039;s Basketball Player of the Week on Monday."/>
<link rel="canonical" href="http://arizonasports.com/story/1781922/asu-basketballs-rob-edwards-named-pac-12-player-of-the-week/?src=rss?src=rss?src=rss?src=rss" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="ASU basketball&#039;s Rob Edwards named Pac-12 Player of the Week" />
<meta property="og:description" content="ASU&#039;s Rob Edwards received the holiday gift of being named the Pac-12&#039;s Men&#039;s Basketball Player of the Week on Monday." />
<meta property="og:url" content="http://arizonasports.com/story/1781922/asu-basketballs-rob-edwards-named-pac-12-player-of-the-week/?src=rss?src=rss?src=rss?src=rss" />
<meta property="og:site_name" content="Arizona Sports" />
<meta property="article:publisher" content="https://www.facebook.com/ArizonaSports" />
<meta property="article:tag" content="ASU" />
<meta property="article:tag" content="Kansas" />
<meta property="article:tag" content="Rob Edwards" />
<meta property="article:tag" content="Vanderbilt" />
<meta property="article:section" content="Arizona State Basketball Stories" />
<meta property="article:published_time" content="2018-12-24T20:14:17+00:00" />
<meta property="og:image" content="http://arizonasports.com/wp-content/uploads/2018/12/rob-edwards.jpg" />
<meta property="og:image:width" content="620" />
<meta property="og:image:height" content="370" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="ASU&#039;s Rob Edwards received the holiday gift of being named the Pac-12&#039;s Men&#039;s Basketball Player of the Week on Monday." />
<meta name="twitter:title" content="ASU basketball&#039;s Rob Edwards named Pac-12 Player of the Week" />
<meta name="twitter:site" content="@azsports" />
<meta name="twitter:image" content="http://arizonasports.com/wp-content/uploads/2018/12/rob-edwards.jpg" />
<meta name="twitter:creator" content="@DannyShapiro13" />
<!-- / Yoast SEO plugin. -->

<link rel="amphtml" href="http://arizonasports.com/story/1781922/asu-basketballs-rob-edwards-named-pac-12-player-of-the-week/amp/?src=rss?src=rss?src=rss?src=rss" /><link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//jwpsrv.com' />
<link rel='dns-prefetch' href='//hosted.stats.com' />
<link rel='dns-prefetch' href='//d26fhcku9pa5f4.cloudfront.net' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//netdna.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//code.jquery.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Arizona Sports &raquo; ASU basketball&#8217;s Rob Edwards named Pac-12 Player of the Week Comments Feed" href="http://arizonasports.com/story/1781922/asu-basketballs-rob-edwards-named-pac-12-player-of-the-week/feed/" />
<link rel='stylesheet' id='wp-polls-css'  href='http://2xnw2mt2bw82xppry3quo8xq.wpengine.netdna-cdn.com/wp-content/plugins/wp-polls/polls-css.css?ver=1.0' type='text/css' media='all' />
<style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 16px;
	line-height: 18px;
	height: 18px;
	background: #DC1A22;
	border: 1px solid #DC1A22;
}

</style>
<link rel='stylesheet' id='3.0-statsshs-css'  href='http://hosted.stats.com/config/shsdefault.css?ver=20170512' type='text/css' media='all' />
<link rel='stylesheet' id='3.0-statsmulti-css'  href='http://hosted.stats.com/config/multidefault.css?ver=20170512' type='text/css' media='all' />
<link rel='stylesheet' id='3.0-main-css'  href='https://d26fhcku9pa5f4.cloudfront.net/web3-main.css?ver=20181212' type='text/css' media='all' />
<link rel='stylesheet' id='3.0-nonhomepage-style-css'  href='https://d26fhcku9pa5f4.cloudfront.net/nonhome.css?ver=20181212' type='text/css' media='all' />
<link rel='stylesheet' id='3.0-nonhomepage-style-override-css'  href='http://2xnw2mt2bw82xppry3quo8xq.wpengine.netdna-cdn.com/wp-content/themes/arizonasports/assets/css/nonhome.css?ver=20170408' type='text/css' media='all' />
<link rel='stylesheet' id='3.0-dark-css'  href='https://d26fhcku9pa5f4.cloudfront.net/dark.css?ver=20181212' type='text/css' media='all' />
<link rel='stylesheet' id='3.0-arizonasports-css'  href='http://2xnw2mt2bw82xppry3quo8xq.wpengine.netdna-cdn.com/wp-content/themes/arizonasports/assets/css/arizonasports.css?ver=20180502' type='text/css' media='all' />
<link rel='stylesheet' id='unity-roboto-slab-css'  href='https://fonts.googleapis.com/css?family=Roboto+Slab%3A400%2C900&#038;ver=4.8.8' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='https://netdna.bootstrapcdn.com/font-awesome/4.0.3/css/font-awesome.css?ver=4.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='events-css'  href='http://2xnw2mt2bw82xppry3quo8xq.wpengine.netdna-cdn.com/wp-content/plugins/tweak-events/assets/css/events.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='jquery-ui-smoothness-css'  href='https://code.jquery.com/ui/1.10.3/themes/smoothness/jquery-ui.css?ver=1.0' type='text/css' media='all' />
<script type='text/javascript' src='https://ajax.googleapis.com/ajax/libs/jquery/1.11.0/jquery.min.js?ver=1.11.0'></script>
<script type='text/javascript' src='https://ajax.googleapis.com/ajax/libs/jqueryui/1.10.4/jquery-ui.min.js?ver=1.10.4'></script>
<script type='text/javascript' src='http://2xnw2mt2bw82xppry3quo8xq.wpengine.netdna-cdn.com/wp-content/themes/arizonasports/assets/js/jquery.functions.js?ver=4.4.14'></script>
<script type='text/javascript' src='https://jwpsrv.com/library/hpH9Jq1TEeSPjQp+lcGdIw.js?ver=2.6'></script>
<link rel='https://api.w.org/' href='http://arizonasports.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://arizonasports.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://arizonasports.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='http://arizonasports.com/?p=1781922' />
<link rel="alternate" type="application/json+oembed" href="http://arizonasports.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Farizonasports.com%2Fstory%2F1781922%2Fasu-basketballs-rob-edwards-named-pac-12-player-of-the-week%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://arizonasports.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Farizonasports.com%2Fstory%2F1781922%2Fasu-basketballs-rob-edwards-named-pac-12-player-of-the-week%2F&#038;format=xml" />
<link rel="canonical" href="http://arizonasports.com/story/1781922/asu-basketballs-rob-edwards-named-pac-12-player-of-the-week/" />
<!-- BEGIN wp-parsely Plugin Version 1.7 -->
<meta name='wp-parsely_version' id='wp-parsely_version' content='1.7' />
   <script type="application/ld+json">
   {"@context":"http:\/\/schema.org","@type":"NewsArticle","headline":"ASU basketball&#8217;s Rob Edwards named Pac-12 Player of the Week","url":"http:\/\/arizonasports.com\/story\/1781922\/asu-basketballs-rob-edwards-named-pac-12-player-of-the-week\/","thumbnailUrl":"http:\/\/arizonasports.com\/wp-content\/uploads\/2018\/12\/rob-edwards-150x150.jpg","articleId":"1781922","dateCreated":"2018-12-24T20:14:17Z","articleSection":"Arizona State Basketball Stories","creator":["Danny Shapiro"],"keywords":["asu","kansas","rob edwards","vanderbilt"]}   </script>
<!-- END wp-parsely Plugin Version 1.7 -->
	<!-- Include google_services.js -->
<script type='text/javascript'>
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
(function() {
var gads = document.createElement('script');
gads.async = true;
gads.type = 'text/javascript';
var useSSL = 'https:' == document.location.protocol;
gads.src = (useSSL ? 'https:' : 'http:') +
'//www.googletagservices.com/tag/js/gpt.js';
var node = document.getElementsByTagName('script')[0];
node.parentNode.insertBefore(gads, node);
})();
</script>
	<!--[if lt IE 9]>
	<script src="http://2xnw2mt2bw82xppry3quo8xq.wpengine.netdna-cdn.com/wp-content/themes/arizonasports/assets/js/html5shiv.js"></script>
	<script type="text/javascript" src="http://2xnw2mt2bw82xppry3quo8xq.wpengine.netdna-cdn.com/wp-content/themes/arizonasports/assets/js/selectivizr.js"></script>
	<![endif]-->

</head>
<body>
	
        <script>

        var versaTag = {};
        versaTag.id = "5532";
        versaTag.sync = 0;
        versaTag.dispType = "js";
        versaTag.ptcl = "HTTPS";
        versaTag.bsUrl = "bs.serving-sys.com/BurstingPipe";
        //VersaTag activity parameters include all conversion parameters including custom parameters and Predefined parameters. Syntax: "ParamName1":"ParamValue1", "ParamName2":"ParamValue2". ParamValue can be empty.
        versaTag.activityParams = {
        //Predefined parameters:
        "OrderID":"","Session":"","Value":"","productid":"","productinfo":"","Quantity":""
        //Custom parameters:
        };
        //Static retargeting tags parameters. Syntax: "TagID1":"ParamValue1", "TagID2":"ParamValue2". ParamValue can be empty.
        versaTag.retargetParams = {};
        //Dynamic retargeting tags parameters. Syntax: "TagID1":"ParamValue1", "TagID2":"ParamValue2". ParamValue can be empty.
        versaTag.dynamicRetargetParams = {};
        // Third party tags conditional parameters and mapping rule parameters. Syntax: "CondParam1":"ParamValue1", "CondParam2":"ParamValue2". ParamValue can be empty.
        versaTag.conditionalParams = {};
        </script>
        <script id="ebOneTagUrlId" src="https://secure-ds.serving-sys.com/SemiCachedScripts/ebOneTag.js"></script>
        <noscript>
        <iframe src="https://bs.serving-sys.com/BurstingPipe?
        cn=ot&amp;
        onetagid=5532&amp;
        ns=1&amp;
        activityValues=$=[Value]&amp;OrderID=[OrderID]&amp;Session=[Session]&amp;ProductID=[ProductID]&amp;ProductInfo=[ProductInfo]&amp;Quantity=[Quantity]$$&amp;
        retargetingValues=$$$$&amp;
        dynamicRetargetingValues=$$$$&amp;
        acp=$$$$&amp;"
        style="display:none;width:0px;height:0px"></iframe>
        </noscript>
        
<div id="menu" class="screencover">
	<div class="menuicon">
		<a href="#" class="close_menu">x</a>
	</div>
	<ul>
		<li><a href="/">Home</a></li>
		<li><a href="/?s=129"><i class="fa fa-search"></i> Search</a></li>
		<li><a href="/listen-live/">Listen Live</a></li>
		<li><a href="/arizona-sports-podcasts/">Podcasts</a></li>
		<li><a href="/top-stories/" class="topLeftMenu" id="topnews" ref="left_head_nav">Top Stories</a></li>
		<li><a href="/dan-bickley/">Dan Bickley</a></li>

		<li class="onlymobile"><a href="http://allstar.ktar.com">Rewards</a></li>
		<li class="onlymobile"><a href="http://ktar.com">KTAR.com</a></li>
		<li class="section">Shows</li>
		<li><a href="/doug-wolf/">Doug &amp; Wolf</a></li>
		<li><a href="/bickley-marotta/">Bickley &amp; Marotta</a></li>
		<li><a href="/burns-gambo/">Burns &amp; Gambo</a></li>
		<li><a href="/category/podcast_results/?sid=1075&n=The%20Rundown%20with%20Luke%20Lapinski">The Rundown with Luke Lapinski</a></li>
		<li><a href="/3/1355312/Arizona-Sports-987">Complete Lineup...</a></li>
		<li class="section">Teams</li>
		<li><a href="/arizona-cardinals/">Cardinals</a></li>
		<li><a href="/phoenix-suns/">Suns</a></li>
		<li><a href="/arizona-diamondbacks/">D-backs</a></li>
		<li><a href="/arizona-coyotes/">Coyotes</a></li>
		<li><a href="/arizona-state-sun-devils/">Sun Devils</a></li>
		<li><a href="/arizona-wildcats/">Wildcats</a></li>
		<li><a href="/arizona-rattlers/">Rattlers</a></li>
		<li><a href="/phoenix-mercury">Mercury</a></li>
		<li><a href="/grand-canyon-lopes/">'Lopes</a></li>
		<li><a href="/northern-arizona-lumberjacks/">Lumberjacks</a></li>
		<li class="section">Special Sections</li>
		<li><a href="/category/character-counts-blogs/">Character Counts</a></li>
    	<li><a href="/haboob-blog/">Haboob Blog</a></li>
    	<li><a href="/category/the-5-blogs/">The 5</a></li>
		<li><a href="/category/threads/">Threads</a></li>
		<li><a href="/cronkite-news-5/">Cronkite Sports</a></li>
	 	<li class="section">98.7 Arizona Sports</li>
    	<li><a href="/Arizona-Sports-987">On-Air Schedule</a></li>
		<li><a href="/category/contests">Rewards</a></li>
		<li><a href="/events/featured">Events</a></li>
    	<li><a href="/starting-five-newsletter-signup/">Newsletter</a></li>
		<li><a href="/text-alerts/">Text Alerts</a></li>
		<li><a href="/the-arizona-sports-98-7-fm-app/">Arizona Sports Apps</a></li>
	    <li><a href="javascript:void()" onclick="popWindow('http://facebook.com/arizonasports')">Facebook</a></li>
	    <li><a href="javascript:void()" onclick="popWindow('http://twitter.com/azsports')">Twitter</a></li>
	    <li><a href="javascript:void()" onclick="popWindow('http://instagram.com/arizsports')">Instagram</a></li>
    </ul>
</div>
<div id="share" class="screencover">
	<div class="menuicon">
		<a href="#" class="close_share">x</a>
	</div>
	<div class="colheader">
		Share this story...
	</div>

						<img width="620" height="370" src="http://2xnw2mt2bw82xppry3quo8xq.wpengine.netdna-cdn.com/wp-content/uploads/2018/12/rob-edwards-620x370.jpg" class="wide-share wp-post-image" alt="" srcset="http://arizonasports.com/wp-content/uploads/2018/12/rob-edwards.jpg 620w, http://arizonasports.com/wp-content/uploads/2018/12/rob-edwards-300x179.jpg 300w, http://arizonasports.com/wp-content/uploads/2018/12/rob-edwards-120x72.jpg 120w, http://arizonasports.com/wp-content/uploads/2018/12/rob-edwards-294x175.jpg 294w, http://arizonasports.com/wp-content/uploads/2018/12/rob-edwards-250x149.jpg 250w" sizes="(max-width: 620px) 100vw, 620px" />			
		<ul>
		<li><div>ASU basketball&#8217;s Rob Edwards named Pac-12 Player of the Week</div></li>
		<li><a href="javascript:void();" onClick="popShare('http://www.facebook.com/sharer.php?u=http%3A%2F%2Farizonasports.com%2Fstory%2F1781922%2Fasu-basketballs-rob-edwards-named-pac-12-player-of-the-week%2F&t=http://arizonasports.com | http%3A%2F%2Farizonasports.com%2Fstory%2F1781922%2Fasu-basketballs-rob-edwards-named-pac-12-player-of-the-week%2F')">Facebook</a></li>
		<li><a href="javascript:void();" onClick="popShare('http://twitter.com/share?text=ASU basketball&#8217;s Rob Edwards named Pac-12 Player of the Week&url=http://arizonasports.com/story/1781922/asu-basketballs-rob-edwards-named-pac-12-player-of-the-week/')">Twitter</a></li>
		<li><a href="javascript:void();" onClick="popShare('http://www.linkedin.com/shareArticle?mini=true&amp;url=http%3A%2F%2Farizonasports.com%2Fstory%2F1781922%2Fasu-basketballs-rob-edwards-named-pac-12-player-of-the-week%2F&amp;title=ASU basketball&#8217;s Rob Edwards named Pac-12 Player of the Week&amp;summary=')">LinkedIn</a></li>
		<li><a href="/email-story/?Subject=The+following+article+has+been+shared+with+you%3A%0A%0AASU+basketball%26%238217%3Bs+Rob+Edwards+named+Pac-12+Player+of+the+Week%0A%0AClick+the+following+link+to+view%3A+http%3A%2F%2Farizonasports.com%2Fstory%2F1781922%2Fasu-basketballs-rob-edwards-named-pac-12-player-of-the-week%2F">Email Story</a></li>
	</ul>


</div>


<div id="wrapper">

	<!--OVERLAY WHEN NAVIGATION IS OPEN-->
	<div id="overlay_back"></div>
	<!--OVERLAY WHEN NAVIGATION IS OPEN-->

	<header>
		<!--HEADER-->
		<div class="headerwrapper primary">

			<div id="topnav">
				<div id="topnav_body">
					<ul class="left">
						<li><a href="https://www.facebook.com/ArizonaSports/" target="_blank"><div class="fa fa-facebook-square fonticon"></div> FACEBOOK</a></li>
						<li><a href="https://twitter.com/azsports" target="_blank"><div class="fa fa-twitter-square fonticon"></div> TWITTER</a></li>
						<li><a href="/arizona-sports-daily-insider-signup/"><div class="fa fa-envelope fonticon"></div> EMAIL ALERTS</a></li>
						<li><a href="/the-arizona-sports-98-7-fm-app/"><div class="fa fa-mobile fonticon"></div> GET THE APP</a></li>
					</ul>

					<ul class="right">
																		<li><span class="news-nav-icon"></span><a href="http://ktar.com/">KTAR News</a></li>
						<li><span class="sports-nav-icon"></span><a style="border-bottom: 1px solid red;" href="http://arizonasports.com">Arizona Sports</a></li>
					</ul>
				</div>
			</div>


			<div class="header">
				<div class="menuicon primary">
					<a href="#" class="menu_link"><i class="fa fa-bars" aria-hidden="true"></i></a>
				</div>
									<div class="shareicon primary">
						<a href="#" class="share_link"><i class="fa fa-share" aria-hidden="true"></i></a>
					</div>
								<ul class="upper">
					<li><a href="/top-stories/" class="border">Top Stories</a></li>
					<li><a href="/listen-live" class="border"><i class="fa fa-circle" aria-hidden="true"></i> Listen Live</a></li>
					<li><a href="/category/podcasts" class="border">Podcasts</a></li>
											<li><a href="/dan-bickley/" class="border">Dan Bickley</a></li>
				  					<li><a href="/category/contests/" class="border">Rewards</a></li>

					<li class="farright secondary"><a href="#" class="menu_link borderlight">Menu <i class="fa fa-bars" aria-hidden="true"></i></a></li>
				</ul>
				<a href="/"><img src="http://2xnw2mt2bw82xppry3quo8xq.wpengine.netdna-cdn.com/wp-content/themes/arizonasports/assets/logo/ArizonaSports_987fm_RGB_blk-bg.svg"></a>

			</div>
		</div>

	</header>
	<!--HEADER-->
	<div id="mobilespacer"></div>
	<div id="deskspacer"></div>
<div class="farleftcolumn">
<div class="colheader">Latest News</div>
<ul class="morestories">
               <li >
              <a href="http://arizonasports.com/story/1782037/arizona-cardinals-claim-d-j-swearinger-off-waivers/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','http://arizonasports.com/story/1782037/arizona-cardinals-claim-d-j-swearinger-off-waivers/','1']);" class="thumb">
                  <img width="60" height="60" src="http://2xnw2mt2bw82xppry3quo8xq.wpengine.netdna-cdn.com/wp-content/uploads/2018/12/dj_swearinger_620x370-60x60.jpg" class="thumb wp-post-image" alt=""  />              </a>
              <a href="http://arizonasports.com/story/1782037/arizona-cardinals-claim-d-j-swearinger-off-waivers/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','http://arizonasports.com/story/1782037/arizona-cardinals-claim-d-j-swearinger-off-waivers/','1']);">
                  <span>Danny Shapiro<br></span>
                  Arizona Cardinals claim D.J. Swearinger off waivers              </a>
		</li>
	         <li >
              <a href="http://arizonasports.com/story/1776025/best-arizona-sports-haboobs-of-2018/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','http://arizonasports.com/story/1776025/best-arizona-sports-haboobs-of-2018/','1']);" class="thumb">
                  <img width="60" height="60" src="http://2xnw2mt2bw82xppry3quo8xq.wpengine.netdna-cdn.com/wp-content/uploads/2018/09/jonah-hill-suns-jersey-60x60.jpg" class="thumb wp-post-image" alt=""  />              </a>
              <a href="http://arizonasports.com/story/1776025/best-arizona-sports-haboobs-of-2018/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','http://arizonasports.com/story/1776025/best-arizona-sports-haboobs-of-2018/','1']);">
                  <span>Haboob Blog<br></span>
                  Best Arizona Sports Haboobs of 2018              </a>
		</li>
	         <li >
              <a href="http://arizonasports.com/story/1782013/arizona-sports-nfl-power-rankings-week-17-saints-hold-rams-move-up/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','http://arizonasports.com/story/1782013/arizona-sports-nfl-power-rankings-week-17-saints-hold-rams-move-up/','1']);" class="thumb">
                  <img width="60" height="60" src="http://2xnw2mt2bw82xppry3quo8xq.wpengine.netdna-cdn.com/wp-content/uploads/2018/12/rsz_1drew_brees-60x60.jpg" class="thumb wp-post-image" alt=""  />              </a>
              <a href="http://arizonasports.com/story/1782013/arizona-sports-nfl-power-rankings-week-17-saints-hold-rams-move-up/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','http://arizonasports.com/story/1782013/arizona-sports-nfl-power-rankings-week-17-saints-hold-rams-move-up/','1']);">
                  <span>Vince Marotta<br></span>
                  Arizona Sports NFL Power Rankings Week 17: Saints hold, Rams move up              </a>
		</li>
	         <li >
              <a href="http://arizonasports.com/story/1352993/trivia-tuesday-getting-into-the-christmas-spirit/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','http://arizonasports.com/story/1352993/trivia-tuesday-getting-into-the-christmas-spirit/','1']);" class="thumb">
                  <img width="60" height="60" src="http://2xnw2mt2bw82xppry3quo8xq.wpengine.netdna-cdn.com/wp-content/uploads/2017/12/TriviaTuesdayXmas-60x60.jpg" class="thumb wp-post-image" alt=""  />              </a>
              <a href="http://arizonasports.com/story/1352993/trivia-tuesday-getting-into-the-christmas-spirit/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','http://arizonasports.com/story/1352993/trivia-tuesday-getting-into-the-christmas-spirit/','1']);">
                  <span>Arizona Sports<br></span>
                  Trivia Tuesday: Getting into the Christmas spirit              </a>
		</li>
	         <li >
              <a href="http://arizonasports.com/story/971750/the-5-how-valley-sports-teams-fared-in-their-most-recent-christmas-games/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','http://arizonasports.com/story/971750/the-5-how-valley-sports-teams-fared-in-their-most-recent-christmas-games/','1']);" class="thumb">
                  <img width="60" height="60" src="http://2xnw2mt2bw82xppry3quo8xq.wpengine.netdna-cdn.com/wp-content/uploads/2016/12/BarkleyHorryShot-60x60.jpg" class="thumb wp-post-image" alt=""  />              </a>
              <a href="http://arizonasports.com/story/971750/the-5-how-valley-sports-teams-fared-in-their-most-recent-christmas-games/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','http://arizonasports.com/story/971750/the-5-how-valley-sports-teams-fared-in-their-most-recent-christmas-games/','1']);">
                  <span>Kevin Zimmerman<br></span>
                  The 5: Arizona teams' most notable Christmas games              </a>
		</li>
	         <li >
              <a href="http://arizonasports.com/story/1781925/cardinals-steve-wilks-expands-on-staying-the-course-amid-turmoils/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','http://arizonasports.com/story/1781925/cardinals-steve-wilks-expands-on-staying-the-course-amid-turmoils/','1']);" class="thumb">
                  <img width="60" height="60" src="http://2xnw2mt2bw82xppry3quo8xq.wpengine.netdna-cdn.com/wp-content/uploads/2018/12/steve-wilks-60x60.jpg" class="thumb wp-post-image" alt=""  />              </a>
              <a href="http://arizonasports.com/story/1781925/cardinals-steve-wilks-expands-on-staying-the-course-amid-turmoils/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','http://arizonasports.com/story/1781925/cardinals-steve-wilks-expands-on-staying-the-course-amid-turmoils/','1']);">
                  <span>Kevin Zimmerman<br></span>
                  Cardinals' Steve Wilks expands on staying the course amid turmoils              </a>
		</li>
	         <li class="active">
              <a href="http://arizonasports.com/story/1781922/asu-basketballs-rob-edwards-named-pac-12-player-of-the-week/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','http://arizonasports.com/story/1781922/asu-basketballs-rob-edwards-named-pac-12-player-of-the-week/','1']);" class="thumb">
                  <img width="60" height="60" src="http://2xnw2mt2bw82xppry3quo8xq.wpengine.netdna-cdn.com/wp-content/uploads/2018/12/rob-edwards-60x60.jpg" class="thumb wp-post-image" alt=""  />              </a>
              <a href="http://arizonasports.com/story/1781922/asu-basketballs-rob-edwards-named-pac-12-player-of-the-week/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','http://arizonasports.com/story/1781922/asu-basketballs-rob-edwards-named-pac-12-player-of-the-week/','1']);">
                  <span>Danny Shapiro<br></span>
                  ASU basketball's Rob Edwards named Pac-12 Player of the Week              </a>
		</li>
	         <li >
              <a href="http://arizonasports.com/story/1781905/nbcs-king-interest-between-former-packers-coach-mccarthy-cardinals/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','http://arizonasports.com/story/1781905/nbcs-king-interest-between-former-packers-coach-mccarthy-cardinals/','1']);" class="thumb">
                  <img width="60" height="60" src="http://2xnw2mt2bw82xppry3quo8xq.wpengine.netdna-cdn.com/wp-content/uploads/2018/12/mike-mccarthy-packers-cardinals-60x60.jpg" class="thumb wp-post-image" alt=""  />              </a>
              <a href="http://arizonasports.com/story/1781905/nbcs-king-interest-between-former-packers-coach-mccarthy-cardinals/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','http://arizonasports.com/story/1781905/nbcs-king-interest-between-former-packers-coach-mccarthy-cardinals/','1']);">
                  <span>Arizona Sports<br></span>
                  NBC's King: Interest between former Packers coach McCarthy, Cardinals              </a>
		</li>
	         <li >
              <a href="http://arizonasports.com/story/1781899/college-basketball-rankings-asu-ap-poll-win-over-kansas/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','http://arizonasports.com/story/1781899/college-basketball-rankings-asu-ap-poll-win-over-kansas/','1']);" class="thumb">
                  <img width="60" height="60" src="http://2xnw2mt2bw82xppry3quo8xq.wpengine.netdna-cdn.com/wp-content/uploads/2018/12/dort-asu-ap-poll-college-basketball-rankings-kansas-60x60.jpg" class="thumb wp-post-image" alt=""  />              </a>
              <a href="http://arizonasports.com/story/1781899/college-basketball-rankings-asu-ap-poll-win-over-kansas/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','http://arizonasports.com/story/1781899/college-basketball-rankings-asu-ap-poll-win-over-kansas/','1']);">
                  <span>Arizona Sports<br></span>
                  ASU moves to No. 17 in AP poll after win over 1st-ranked Kansas              </a>
		</li>
	         <li >
              <a href="http://arizonasports.com/story/1781896/cardinals-coach-steve-wilks-support-peanut-tillman/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','http://arizonasports.com/story/1781896/cardinals-coach-steve-wilks-support-peanut-tillman/','1']);" class="thumb">
                  <img width="60" height="60" src="http://2xnw2mt2bw82xppry3quo8xq.wpengine.netdna-cdn.com/wp-content/uploads/2018/12/peanut-tillman-steve-wilks-60x60.jpg" class="thumb wp-post-image" alt=""  />              </a>
              <a href="http://arizonasports.com/story/1781896/cardinals-coach-steve-wilks-support-peanut-tillman/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','http://arizonasports.com/story/1781896/cardinals-coach-steve-wilks-support-peanut-tillman/','1']);">
                  <span>Kevin Zimmerman<br></span>
                  Steve Wilks receives support from former DB Peanut Tillman              </a>
		</li>
	         <li >
              <a href="http://arizonasports.com/story/1781557/cardinals-loss-to-rams-brings-new-mark-for-home-futility/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','http://arizonasports.com/story/1781557/cardinals-loss-to-rams-brings-new-mark-for-home-futility/','1']);" class="thumb">
                  <img width="60" height="60" src="http://2xnw2mt2bw82xppry3quo8xq.wpengine.netdna-cdn.com/wp-content/uploads/2018/12/CardinalsFan_MA4-60x60.jpg" class="thumb wp-post-image" alt=""  />              </a>
              <a href="http://arizonasports.com/story/1781557/cardinals-loss-to-rams-brings-new-mark-for-home-futility/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','http://arizonasports.com/story/1781557/cardinals-loss-to-rams-brings-new-mark-for-home-futility/','1']);">
                  <span>Vince Marotta<br></span>
                  Cardinals' loss to Rams brings new mark for home futility              </a>
		</li>
	         <li >
              <a href="http://arizonasports.com/story/1781800/galchenyuk-scores-twice-as-coyotes-outlast-sharks-in-overtime/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','http://arizonasports.com/story/1781800/galchenyuk-scores-twice-as-coyotes-outlast-sharks-in-overtime/','1']);" class="thumb">
                  <img width="60" height="60" src="http://2xnw2mt2bw82xppry3quo8xq.wpengine.netdna-cdn.com/wp-content/uploads/2018/12/gally-60x60.jpg" class="thumb wp-post-image" alt=""  />              </a>
              <a href="http://arizonasports.com/story/1781800/galchenyuk-scores-twice-as-coyotes-outlast-sharks-in-overtime/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','http://arizonasports.com/story/1781800/galchenyuk-scores-twice-as-coyotes-outlast-sharks-in-overtime/','1']);">
                  <span>Associated Press<br></span>
                  Galchenyuk scores twice as Coyotes outlast Sharks in overtime              </a>
		</li>
	         <li >
              <a href="http://arizonasports.com/story/1781725/bickley-absurdity-of-arizona-cardinals-season-has-reached-new-low/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','http://arizonasports.com/story/1781725/bickley-absurdity-of-arizona-cardinals-season-has-reached-new-low/','1']);" class="thumb">
                  <img width="60" height="60" src="http://2xnw2mt2bw82xppry3quo8xq.wpengine.netdna-cdn.com/wp-content/uploads/2018/12/rosen-bickley-60x60.jpg" class="thumb wp-post-image" alt=""  />              </a>
              <a href="http://arizonasports.com/story/1781725/bickley-absurdity-of-arizona-cardinals-season-has-reached-new-low/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','http://arizonasports.com/story/1781725/bickley-absurdity-of-arizona-cardinals-season-has-reached-new-low/','1']);">
                  <span>Dan Bickley<br></span>
                  Absurdity of Arizona Cardinals' season has reached new low              </a>
		</li>
	         <li >
              <a href="http://arizonasports.com/story/1781546/larry-fitzgerald-not-soaking-in-potentially-final-home-game/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','http://arizonasports.com/story/1781546/larry-fitzgerald-not-soaking-in-potentially-final-home-game/','1']);" class="thumb">
                  <img width="60" height="60" src="http://2xnw2mt2bw82xppry3quo8xq.wpengine.netdna-cdn.com/wp-content/uploads/2018/12/fitzleavesfield-60x60.jpg" class="thumb wp-post-image" alt=""  />              </a>
              <a href="http://arizonasports.com/story/1781546/larry-fitzgerald-not-soaking-in-potentially-final-home-game/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','http://arizonasports.com/story/1781546/larry-fitzgerald-not-soaking-in-potentially-final-home-game/','1']);">
                  <span>Tyler Drake<br></span>
                  Larry Fitzgerald 'not soaking in' potentially final home game              </a>
		</li>
	         <li >
              <a href="http://arizonasports.com/story/1781264/after-loss-to-rams-cardinals-wilks-remains-focused-on-job-at-hand/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','http://arizonasports.com/story/1781264/after-loss-to-rams-cardinals-wilks-remains-focused-on-job-at-hand/','1']);" class="thumb">
                  <img width="60" height="60" src="http://2xnw2mt2bw82xppry3quo8xq.wpengine.netdna-cdn.com/wp-content/uploads/2018/12/wilks-rosen-60x60.jpg" class="thumb wp-post-image" alt=""  />              </a>
              <a href="http://arizonasports.com/story/1781264/after-loss-to-rams-cardinals-wilks-remains-focused-on-job-at-hand/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','http://arizonasports.com/story/1781264/after-loss-to-rams-cardinals-wilks-remains-focused-on-job-at-hand/','1']);">
                  <span>Kevin Zimmerman<br></span>
                  After loss to Rams, Cardinals' Wilks remains focused on job at hand              </a>
		</li>
	         <li >
              <a href="http://arizonasports.com/story/1781450/complexity-of-deandre-aytons-outlook-shown-in-suns-recent-two-game-spurt/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','http://arizonasports.com/story/1781450/complexity-of-deandre-aytons-outlook-shown-in-suns-recent-two-game-spurt/','1']);" class="thumb">
                  <img width="60" height="60" src="http://2xnw2mt2bw82xppry3quo8xq.wpengine.netdna-cdn.com/wp-content/uploads/2018/12/ayton-celtics-60x60.jpg" class="thumb wp-post-image" alt=""  />              </a>
              <a href="http://arizonasports.com/story/1781450/complexity-of-deandre-aytons-outlook-shown-in-suns-recent-two-game-spurt/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','http://arizonasports.com/story/1781450/complexity-of-deandre-aytons-outlook-shown-in-suns-recent-two-game-spurt/','1']);">
                  <span>Kellan Olson<br></span>
                  Complexity of Deandre Ayton's outlook shown in Suns' recent two-game spurt              </a>
		</li>
	         <li >
              <a href="http://arizonasports.com/story/1781583/weary-suns-fall-to-brooklyn-for-second-consecutive-loss/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','http://arizonasports.com/story/1781583/weary-suns-fall-to-brooklyn-for-second-consecutive-loss/','1']);" class="thumb">
                  <img width="60" height="60" src="http://2xnw2mt2bw82xppry3quo8xq.wpengine.netdna-cdn.com/wp-content/uploads/2018/12/ayton-nets-60x60.jpg" class="thumb wp-post-image" alt=""  />              </a>
              <a href="http://arizonasports.com/story/1781583/weary-suns-fall-to-brooklyn-for-second-consecutive-loss/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','http://arizonasports.com/story/1781583/weary-suns-fall-to-brooklyn-for-second-consecutive-loss/','1']);">
                  <span>Associated Press<br></span>
                  Weary Suns fall to Brooklyn for second consecutive loss              </a>
		</li>
	         <li >
              <a href="http://arizonasports.com/story/1781484/rapid-reactions-arizona-cardinals-blown-out-by-rams-in-home-finale/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','http://arizonasports.com/story/1781484/rapid-reactions-arizona-cardinals-blown-out-by-rams-in-home-finale/','1']);" class="thumb">
                  <img width="60" height="60" src="http://2xnw2mt2bw82xppry3quo8xq.wpengine.netdna-cdn.com/wp-content/uploads/2018/12/larry-fitzgerald-rr-60x60.jpg" class="thumb wp-post-image" alt=""  />              </a>
              <a href="http://arizonasports.com/story/1781484/rapid-reactions-arizona-cardinals-blown-out-by-rams-in-home-finale/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','http://arizonasports.com/story/1781484/rapid-reactions-arizona-cardinals-blown-out-by-rams-in-home-finale/','1']);">
                  <span>Arizona Sports<br></span>
                  Rapid Reactions: Arizona Cardinals blown out by Rams in home finale              </a>
		</li>
	         <li >
              <a href="http://arizonasports.com/story/1781333/cardinals-larry-fitzgerald-throws-first-career-touchdown-pass/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','http://arizonasports.com/story/1781333/cardinals-larry-fitzgerald-throws-first-career-touchdown-pass/','1']);" class="thumb">
                  <img width="60" height="60" src="http://2xnw2mt2bw82xppry3quo8xq.wpengine.netdna-cdn.com/wp-content/uploads/2018/12/larry-fitz-pass-60x60.jpg" class="thumb wp-post-image" alt=""  />              </a>
              <a href="http://arizonasports.com/story/1781333/cardinals-larry-fitzgerald-throws-first-career-touchdown-pass/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','http://arizonasports.com/story/1781333/cardinals-larry-fitzgerald-throws-first-career-touchdown-pass/','1']);">
                  <span>Danny Shapiro<br></span>
                  Cardinals' Larry Fitzgerald throws first career touchdown pass              </a>
		</li>
	         <li >
              <a href="http://arizonasports.com/story/1781071/rams-rb-todd-gurley-inactive-cardinals-cb-patrick-peterson-in/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','http://arizonasports.com/story/1781071/rams-rb-todd-gurley-inactive-cardinals-cb-patrick-peterson-in/','1']);" class="thumb">
                  <img width="60" height="60" src="http://2xnw2mt2bw82xppry3quo8xq.wpengine.netdna-cdn.com/wp-content/uploads/2018/12/gurley-edit-1-60x60.jpg" class="thumb wp-post-image" alt=""  />              </a>
              <a href="http://arizonasports.com/story/1781071/rams-rb-todd-gurley-inactive-cardinals-cb-patrick-peterson-in/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','http://arizonasports.com/story/1781071/rams-rb-todd-gurley-inactive-cardinals-cb-patrick-peterson-in/','1']);">
                  <span>Kevin Zimmerman<br></span>
                  Rams RB Todd Gurley inactive; Cardinals CB Patrick Peterson in              </a>
		</li>
	</ul>
</div>
<div id="wrapper">
	<div id="mainbody">
					<div style="z-index:-1;" id="adtop" class="primaryad">
      			</div>
    
<!-- Content -->
<article itemscope itemtype="http://schema.org/Article" class="pad">
            <div id="holder">
          
                                              <!--HEADLINE AND ART-->
            <div class="lead primary">
                              <div class="category"><a href="http://arizonasports.com/category/asu-bb-stories/">Arizona State Basketball Stories</a></div>
                <h1 itemprop="name headline">ASU basketball&#8217;s Rob Edwards named Pac-12 Player of the Week</h1>
                <div class="byline">
                    <div class="share-button right">
                        <a href="#" class="share_link">Share &nbsp; <i class="fa fa-share" aria-hidden="true"></i></a>
                    </div>

                    
                        
                             By <a href="http://arizonasports.com/story/author/dshapiro/" style="font-weight:500;"><span itemprop="author">Danny Shapiro</span></a><br>
                            <span class="small"><span itemprop="datePublished" content="December 24, 2018 1:14 pm">December 24, 2018 at 1:14 pm</span></span>

                        
                    
                </div>
            </div>
            <!--HEADLINE AND ART-->

            <!--STORY-->
            <div class="story">
                <!-- Image Block -->
                                                                                        <div id="horiz_photo" >
                                <img class="storyimg" itemprop="image" src="http://2xnw2mt2bw82xppry3quo8xq.wpengine.netdna-cdn.com/wp-content/uploads/2018/12/rob-edwards.jpg" />
                                <div class="caption">Arizona State guard Rob Edwards, left, knocks the ball away from Kansas guard Quentin Grimes during the first half of an NCAA college basketball game Saturday, Dec. 22, 2018, in Tempe, Ariz. (AP Photo/Rick Scuteri)</div>
                            </div>

                            
                                                            

                <p>Rob Edwards&#8217; most productive week as a Sun Devil didn&#8217;t go unnoticed.</p>
<p>Edwards received the holiday gift of being named the Pac-12&#8217;s Men&#8217;s Basketball Player of the Week on Monday following strong performances against Vanderbilt and then-No. 1 Kansas.</p>
<p>It is the first Pac-12 weekly honor for Edwards, the transfer guard from Detroit, and fourth in seven weeks for the Sun Devils.</p>
<p>Edwards averaged 14.5 points per game on 50 percent shooting &#8212; 56 percent from 3-point land &#8212; off the bench in the two games.</p><div style="text-align: center;"><script type='text/javascript'>
googletag.cmd.push(function() {
	//Nick, I’m the happiest if you use me for the default ad mapping
    var mappingDefault = googletag.sizeMapping().
    // Same width as mapping above, more available height
    addSize([320, 400], [300, 250]).
    // Landscape tablet
    addSize([750, 200], [[300, 250],[300,600]]).build();

	var mappingDesktop = googletag.sizeMapping().
	// Same width as mapping above, more available height
	addSize([320, 400], [0, 0]).
	// Landscape tablet
	addSize([750, 200], [300, 250]).build();

    var mappingMobile = googletag.sizeMapping().
    // mobile ad
    addSize([320, 400], [300, 250]).
    // hide tablet or desktop ad
    addSize([750, 200], [0,0]).build();
googletag.defineSlot('/1034751/sports_only_ads', [[300,250]], "acm-ad-tag-sports_only_ads-5c2322a17f48d8.07694919").defineSizeMapping(mappingMobile).addService(googletag.pubads()).setCollapseEmptyDiv(true,true);
googletag.pubads().collapseEmptyDivs();
googletag.enableServices();
});
</script>

<div id='acm-ad-tag-sports_only_ads-5c2322a17f48d8.07694919' class='sports_only_ads mobile_300x250'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('acm-ad-tag-sports_only_ads-5c2322a17f48d8.07694919'); });
</script>
</div>
</div></p>
<p>The redshirt junior had a then-season high 14 points on Monday against Vanderbilt, but really earned the award for his performance against Kansas.</p>
<div class="relatedLinks alignleft"><div class="colheader">Related Links</div><div><ul class="head_list"><li><a href="http://arizonasports.com/story/1780962/viral-tweet-could-lead-to-awkward-tattoo-after-asu-upsets-kansas/" onclick="_gaq.push(['_trackEvent','article','related links','1780962'])">Viral tweet could lead to awkward tattoo after ASU upsets Kansas</a></li><li><a href="http://arizonasports.com/story/1780619/arizona-state-upset-kansas-hurley-martin/" onclick="_gaq.push(['_trackEvent','article','related links','1780619'])">No. 18 ASU shows resiliency, rides wild atmosphere to upset No. 1 Kansas</a></li><li><a href="http://arizonasports.com/story/1780702/arizona-state-fans-storm-court-after-upset-win-over-kansas/" onclick="_gaq.push(['_trackEvent','article','related links','1780702'])">Arizona State fans storm court after upset win over Kansas</a></li></ul></div></div>
<p>Edwards was huge for the Sun Devils in the decisive second half, scoring 13 of his 15 points after halftime.</p>
<p>It was Edwards&#8217; 3-pointer with 2:23 left that gave ASU its first lead and he hit two free throws in the final 10 seconds to secure the victory.</p>
<p>The No. 17 Sun Devils (8-2) return to action on Saturday at home against Princeton at 2 p.m.</p>
<p><a class="twitter-follow-button" href="https://twitter.com/DannyShapiro13" data-show-count="false">Follow @DannyShapiro13</a><script async src="//platform.twitter.com/widgets.js" charset="utf-8"></script></p>
                
                <div class="lowertools">
                    <ul>
                        
                                                    <li><a href="?show=comments#comments" onclick="_gaq.push(['_trackEvent','ArizonaSports Article','http://arizonasports.com/story/1781922/asu-basketballs-rob-edwards-named-pac-12-player-of-the-week/','Comments']);"><span class="disqus-comment-count" data-disqus-url="http://arizonasports.com/story/1781922/asu-basketballs-rob-edwards-named-pac-12-player-of-the-week/"></span> Comments &nbsp; <i class="fa fa-comments" aria-hidden="true"></i></a></li>
                                                <li><a href="#" class="share_link"> Share &nbsp; <i class="fa fa-share" aria-hidden="true"></i></a></li>
                    </ul>
                </div>

                <div style="clear:both;"></div>
                <div id="article_footer">

                    <div class="bottom_cluster">
                                                    
<div class="lowerstories">
    <div class="colheader">
                    Top Stories            </div>
    <ul>
            <li>
            <a href="http://arizonasports.com/story/1776025/best-arizona-sports-haboobs-of-2018/" onclick="_gaq.push(['_trackEvent','ArizonaSports Article','http://arizonasports.com/story/1776025/best-arizona-sports-haboobs-of-2018/','Top_Stories_1']);">
                <img width="250" height="149" src="https://arizonasports.com/wp-content/uploads/2018/09/jonah-hill-suns-jersey-250x149.jpg" class="attachment-post_list size-post_list" alt="" srcset="https://arizonasports.com/wp-content/uploads/2018/09/jonah-hill-suns-jersey-250x149.jpg 250w, https://arizonasports.com/wp-content/uploads/2018/09/jonah-hill-suns-jersey-300x179.jpg 300w, https://arizonasports.com/wp-content/uploads/2018/09/jonah-hill-suns-jersey.jpg 620w, https://arizonasports.com/wp-content/uploads/2018/09/jonah-hill-suns-jersey-120x72.jpg 120w, https://arizonasports.com/wp-content/uploads/2018/09/jonah-hill-suns-jersey-294x175.jpg 294w" sizes="(max-width: 250px) 100vw, 250px" />            </a>
            <a href="http://arizonasports.com/story/1776025/best-arizona-sports-haboobs-of-2018/" class="subline" onclick="_gaq.push(['_trackEvent','ArizonaSports Article','http://arizonasports.com/story/1776025/best-arizona-sports-haboobs-of-2018/','Top_Stories_1']);">
                <b>Best Arizona Sports Haboobs of 2018</b>
            </a>
        </li>
	                            					<li style="position:relative;" >
		
		<a href="http://arizonasports.com/story/1782013/arizona-sports-nfl-power-rankings-week-17-saints-hold-rams-move-up/" onclick="_gaq.push(['_trackEvent','ArizonaSports Article','http://arizonasports.com/story/1782013/arizona-sports-nfl-power-rankings-week-17-saints-hold-rams-move-up/','Top_Stories_2']);">
			<!--<img src="http://2xnw2mt2bw82xppry3quo8xq.wpengine.netdna-cdn.com/wp-content/uploads/2018/12/rsz_1drew_brees-300x179.jpg" alt="Arizona Sports NFL Power Rankings for Week 17" width="250">-->
			<img width="250" height="149" src="https://arizonasports.com/wp-content/uploads/2018/12/rsz_1drew_brees-250x149.jpg" class="attachment-post_list size-post_list" alt="" srcset="https://arizonasports.com/wp-content/uploads/2018/12/rsz_1drew_brees-250x149.jpg 250w, https://arizonasports.com/wp-content/uploads/2018/12/rsz_1drew_brees-300x179.jpg 300w, https://arizonasports.com/wp-content/uploads/2018/12/rsz_1drew_brees.jpg 620w, https://arizonasports.com/wp-content/uploads/2018/12/rsz_1drew_brees-120x72.jpg 120w, https://arizonasports.com/wp-content/uploads/2018/12/rsz_1drew_brees-294x175.jpg 294w" sizes="(max-width: 250px) 100vw, 250px" />		</a>
		<a href="http://arizonasports.com/story/1782013/arizona-sports-nfl-power-rankings-week-17-saints-hold-rams-move-up/" class="subline" onclick="_gaq.push(['_trackEvent','ArizonaSports Article','http://arizonasports.com/story/1782013/arizona-sports-nfl-power-rankings-week-17-saints-hold-rams-move-up/','Top_Stories_2']);">
			<b>Arizona Sports NFL Power Rankings for Week 17</b>
		</a>

	</li>
						<li style="position:relative;" >
		
		<a href="http://arizonasports.com/story/1781557/cardinals-loss-to-rams-brings-new-mark-for-home-futility/" onclick="_gaq.push(['_trackEvent','ArizonaSports Article','http://arizonasports.com/story/1781557/cardinals-loss-to-rams-brings-new-mark-for-home-futility/','Top_Stories_3']);">
			<!--<img src="http://2xnw2mt2bw82xppry3quo8xq.wpengine.netdna-cdn.com/wp-content/uploads/2018/12/CardinalsFan_MA4-300x179.jpg" alt="Cardinals&#039; loss to Rams brings new mark for home futility" width="250">-->
			<img width="250" height="149" src="https://arizonasports.com/wp-content/uploads/2018/12/CardinalsFan_MA4-250x149.jpg" class="attachment-post_list size-post_list" alt="" srcset="https://arizonasports.com/wp-content/uploads/2018/12/CardinalsFan_MA4-250x149.jpg 250w, https://arizonasports.com/wp-content/uploads/2018/12/CardinalsFan_MA4-620x370.jpg 620w, https://arizonasports.com/wp-content/uploads/2018/12/CardinalsFan_MA4-300x179.jpg 300w" sizes="(max-width: 250px) 100vw, 250px" />		</a>
		<a href="http://arizonasports.com/story/1781557/cardinals-loss-to-rams-brings-new-mark-for-home-futility/" class="subline" onclick="_gaq.push(['_trackEvent','ArizonaSports Article','http://arizonasports.com/story/1781557/cardinals-loss-to-rams-brings-new-mark-for-home-futility/','Top_Stories_3']);">
			<b>Cardinals&#39; loss to Rams brings new mark for home futility</b>
		</a>

	</li>
						<li style="position:relative;" >
		
		<a href="http://arizonasports.com/story/1781896/cardinals-coach-steve-wilks-support-peanut-tillman/" onclick="_gaq.push(['_trackEvent','ArizonaSports Article','http://arizonasports.com/story/1781896/cardinals-coach-steve-wilks-support-peanut-tillman/','Top_Stories_4']);">
			<!--<img src="http://2xnw2mt2bw82xppry3quo8xq.wpengine.netdna-cdn.com/wp-content/uploads/2018/12/peanut-tillman-steve-wilks-300x179.jpg" alt="Steve Wilks receives support from former DB Peanut Tillman" width="250">-->
			<img width="250" height="149" src="https://arizonasports.com/wp-content/uploads/2018/12/peanut-tillman-steve-wilks-250x149.jpg" class="attachment-post_list size-post_list" alt="" srcset="https://arizonasports.com/wp-content/uploads/2018/12/peanut-tillman-steve-wilks-250x149.jpg 250w, https://arizonasports.com/wp-content/uploads/2018/12/peanut-tillman-steve-wilks-300x179.jpg 300w, https://arizonasports.com/wp-content/uploads/2018/12/peanut-tillman-steve-wilks.jpg 620w, https://arizonasports.com/wp-content/uploads/2018/12/peanut-tillman-steve-wilks-120x72.jpg 120w, https://arizonasports.com/wp-content/uploads/2018/12/peanut-tillman-steve-wilks-294x175.jpg 294w" sizes="(max-width: 250px) 100vw, 250px" />		</a>
		<a href="http://arizonasports.com/story/1781896/cardinals-coach-steve-wilks-support-peanut-tillman/" class="subline" onclick="_gaq.push(['_trackEvent','ArizonaSports Article','http://arizonasports.com/story/1781896/cardinals-coach-steve-wilks-support-peanut-tillman/','Top_Stories_4']);">
			<b>Steve Wilks receives support from former DB Peanut Tillman</b>
		</a>

	</li>
	
</ul>

</div>                                            </div>
                    
                                                                
                </div>


            </div>
            <!--STORY-->

            <!--RIGHT COLUMN...BELOW STORY ON MOBILE-->
            <div class="rightcolumn">
        <div style="margin-bottom: 30px; text-align:center;">
      <script>
jQuery(document).ready(function($){

        googletag.cmd.push(function() {
        googletag.defineSlot('/1034751/sports_only_ads', [[300,250], [300,600]], "takeover-ad-tag-sports_only_ads-5c2322a183f940.41774038").addService(googletag.pubads());
        googletag.pubads().enableSingleRequest();
        googletag.pubads().collapseEmptyDivs();
        googletag.enableServices();
        });

        googletag.cmd.push(function() { googletag.display('takeover-ad-tag-sports_only_ads-5c2322a183f940.41774038'); });

});
</script>
<div id='takeover-ad-tag-sports_only_ads-5c2322a183f940.41774038' class='sports_only_ads'>
</div>
    </div>
    <div class="subleads">

    <div class="colheader">
            Most Popular          </div>
    
    <ul class="head_list">
                    <li><a href="https://arizonasports.com/story/971750/the-5-how-valley-sports-teams-fared-in-their-most-recent-christmas-games/"  onclick="_gaq.push(['_trackEvent','Most Popular','https://arizonasports.com/story/971750/the-5-how-valley-sports-teams-fared-in-their-most-recent-christmas-games/','Headline 1']);">The 5: Arizona teams&#39; most notable Christmas games</a></li>
                      <li><a href="https://arizonasports.com/story/1781905/nbcs-king-interest-between-former-packers-coach-mccarthy-cardinals/"  onclick="_gaq.push(['_trackEvent','Most Popular','https://arizonasports.com/story/1781905/nbcs-king-interest-between-former-packers-coach-mccarthy-cardinals/','Headline 2']);">NBC&#39;s King: Interest between former Packers coach McCarthy, Cardinals</a></li>
                      <li><a href="https://arizonasports.com/story/1781899/college-basketball-rankings-asu-ap-poll-win-over-kansas/"  onclick="_gaq.push(['_trackEvent','Most Popular','https://arizonasports.com/story/1781899/college-basketball-rankings-asu-ap-poll-win-over-kansas/','Headline 3']);">ASU moves to No. 17 in AP poll after win over 1st-ranked Kansas</a></li>
                    
      <li><a href="/arizona-sports-newsletter-signup/"  onclick="_gaq.push(['_trackEvent','Most Popular','Newsletter','Headline 4']);">Sign up for the Arizona Sports Insider email</a></li>

    </ul>

</div>
            <div class="textwidget custom-html-widget"><h3>Sun Devils Interviews and Podcasts</h3>
<iframe src="https://omny.fm/shows/98-7-fm-arizona-s-sports-station/playlists/arizona-state-sun-devils-interviews-and-podcasts/embed?style=cover&size=square" width="100%" height="700" frameborder="0"></iframe></div>    </div>
            <!--RIGHT COLUMN...BELOW STORY ON MOBILE-->


            <!--STORY HOLDER-->

        </div>
    </article> <!-- End Content -->
	</div>
</div>

<div id="bottom_mobile_heads">
</div>
<div id="footwrapper">
	<div id="footbody" class="primary">
		<footer>

		<a href="/"><img src="http://2xnw2mt2bw82xppry3quo8xq.wpengine.netdna-cdn.com/wp-content/themes/arizonasports/assets/logo/ArizonaSports_4C_blk-bg.svg" alt="Arizona Sports Now On 98.7 FM" style="width:300px;border:none;"></a><br>
		<span>Phoenix, Arizona, USA</span>

		<ul class="footlisten">
			<li>
				<div style="float:left;">On the radio:</div><div style="float:right;"><a href="/listen-live/">98.7 FM</a></div>
			</li>
			<li>
				<div style="float:left;">Online:</div><div style="float:right;"><a href="/">ArizonaSports.com</a></div>
			</li>
			<li>
				<div style="float:left;">On Your Phone:</div><div style="float:right;"><a href="/the-arizona-sports-98-7-fm-app/">98.7 Arizona Sports Apps</a></div>
			</li>
			<li>
				<div style="float:left;">On Demand:</div><div style="float:right;"><a href="/arizona-sports-podcasts/">98.7 Arizona Sports Podcasts</a></div>
			</li>
			<li>
				<div style="float:left;">More:</div><div style="float:right;"><a href="https://itunes.apple.com/" target="new">iTunes</a>, <a href="http://tunein.com/radio/Arizona-Sports-620-s55378/" target="new">TuneIn</a>, <a href="http://stitcher.com" target="new">Stitcher</a></div>
			</li>
			<li>
				<div style="float:left;">Call In:</div><div style="float:right;"><a href="tel:602.274.6200">602.274.6200</a></div>
			</li>
			<li>
				<div style="float:left;">Text In:</div><div style="float:right;"><a href="/text-alerts/">620620</a></div>
			</li>
		</ul>



			<ul class="footlinks">
				<li><a href="/contact-us/">Contact Us</a></li>
				<li>
					 <a href="http://2xnw2mt2bw82xppry3quo8xq.wpengine.netdna-cdn.com/wp-content/uploads/2018/06/General-Contest-Rules-KMVP.pdf">Contest Rules</a>
				</li>
				<li><a href="http://facebook.com/arizonasports">Follow on Facebook</a></li>
				<li><a href="http://twitter.com/azsports">Follow on Twitter</a></li>
				<li><a href="/98/1602357/Sign-Up">Email Alerts</a></li>
                <!--<li><a href="#">Site Map</a></li>
                <li><a href="http://jobs.bonnint.net/">Advertise With Us</a></li>-->
                <li><a href="http://bonneville.com/careers">Employment</a></li>
            </ul>


			<div class="copyright">© 2018 Bonneville International. <a href="/2011/01/03/terms-of-use/">Terms of Use</a> and <a href="/2011/01/03/privacy-statement/">Privacy Policy</a>. All rights reserved.<br><a href="http://ktar.com/wp-content/uploads/2018/05/PHX-SF-Joint-EEO-Public-File-Report-20172018.pdf">EEO Public File Report</a>.  <a href="/story/979712/copyright-info/">Copyright Infringement</a>  <br /> FCC Public File: <a href="https://publicfiles.fcc.gov/fm-profile/kmvp-fm" target="_blank">KMVP-FM</a>  &#149; <a href="https://publicfiles.fcc.gov/am-profile/ktar" target="_blank">KTAR-AM</a> &#149; <a href="https://publicfiles.fcc.gov/am-profile/kmvp" target="_blank">KMVP-AM</a> | FCC Station Representative: Ashley Mannion &#149; <a href="mailto:amannion@bonneville.com?subject=Need Assist with FCC Public File">amannion@bonneville.com</a> &#149; 602.200.2638 </div>



		</footer>
	</div>
</div>
<script id="dsq-count-scr" src="//arizonasports.disqus.com/count.js" async></script>

<!-- START Parse.ly Include: Standard -->
<div id="parsely-root" style="display: none">
  <div id="parsely-cfg" data-parsely-site="arizonasports.com"></div>
</div>
<script>
(function(s, p, d) {
  var h=d.location.protocol, i=p+"-"+s,
      e=d.getElementById(i), r=d.getElementById(p+"-root"),
      u=h==="https:"?"d1z2jf7jlzjs58.cloudfront.net"
      :"static."+p+".com";
  if (e) return;
  e = d.createElement(s); e.id = i; e.async = true;
  e.src = h+"//"+u+"/p.js"; r.appendChild(e);
})("script", "parsely", document);
</script>
<!-- END Parse.ly Include: Standard -->
<script type='text/javascript' src='http://2xnw2mt2bw82xppry3quo8xq.wpengine.netdna-cdn.com/wp-content/plugins/ad-code-timing/assets/js/mobile-detect.min.js?ver=1.0'></script>
<script type='text/javascript' src='http://2xnw2mt2bw82xppry3quo8xq.wpengine.netdna-cdn.com/wp-content/plugins/ad-code-timing/assets/js/jquery.cookie.js?ver=1.0'></script>
<script type='text/javascript' src='http://2xnw2mt2bw82xppry3quo8xq.wpengine.netdna-cdn.com/wp-content/plugins/ad-code-timing/assets/js/takeover.js?ver=1.1'></script>
<script type='text/javascript'>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</script>
<script type='text/javascript' src='http://2xnw2mt2bw82xppry3quo8xq.wpengine.netdna-cdn.com/wp-content/plugins/quick-pagepost-redirect-plugin/js/qppr_frontend_script.min.js?ver=5.1.5'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"http:\/\/arizonasports.com\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://2xnw2mt2bw82xppry3quo8xq.wpengine.netdna-cdn.com/wp-content/plugins/wp-polls/polls-js.js?ver=2.73.8'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var share = {"url":"http:\/\/arizonasports.com\/story\/1781922\/asu-basketballs-rob-edwards-named-pac-12-player-of-the-week\/"};
/* ]]> */
</script>
<script type='text/javascript' src='http://2xnw2mt2bw82xppry3quo8xq.wpengine.netdna-cdn.com/wp-content/themes/arizonasports/assets/js/sharecounts.js?ver=1.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var data = {"ajax_url":"http:\/\/arizonasports.com\/wp-admin\/admin-ajax.php","a_value":"10"};
var data = {"ajax_url":"http:\/\/arizonasports.com\/wp-admin\/admin-ajax.php","a_value":"10"};
/* ]]> */
</script>
<script type='text/javascript' src='http://2xnw2mt2bw82xppry3quo8xq.wpengine.netdna-cdn.com/wp-content/plugins/tweak-events/assets/js/plusdate.js?ver=1.0'></script>
<script type='text/javascript' src='http://2xnw2mt2bw82xppry3quo8xq.wpengine.netdna-cdn.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://2xnw2mt2bw82xppry3quo8xq.wpengine.netdna-cdn.com/wp-includes/js/jquery/ui/datepicker.min.js?ver=1.11.4'></script>
<script type='text/javascript'>
jQuery(document).ready(function(jQuery){jQuery.datepicker.setDefaults({"closeText":"Close","currentText":"Today","monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Previous","dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"dateFormat":"MM d, yy","firstDay":1,"isRTL":false});});
</script>
<script type='text/javascript' src='http://2xnw2mt2bw82xppry3quo8xq.wpengine.netdna-cdn.com/wp-content/plugins/tweak-events/assets/js/datepicker.js?ver=1.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var data = {"ajax_url":"http:\/\/arizonasports.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://2xnw2mt2bw82xppry3quo8xq.wpengine.netdna-cdn.com/wp-content/plugins/tweak-events/assets/js/event-submit-validate.js?ver=1.1'></script>
<script type='text/javascript' src='http://2xnw2mt2bw82xppry3quo8xq.wpengine.netdna-cdn.com/wp-content/plugins/tweak-events/assets/js/datepicker-submit.js?ver=1.0'></script>
<script type='text/javascript' src='http://2xnw2mt2bw82xppry3quo8xq.wpengine.netdna-cdn.com/wp-includes/js/wp-embed.min.js?ver=4.8.8'></script>
<!-- Sourcepoint --><script async="async" data-client-id="gbfrwGXjjAfkpzh" type="text/javascript" src="//d1xfq2052q7thw.cloudfront.net/2.0.1115.js"></script><!-- /Sourcepoint -->
<!-- Analytics -->
<!-- Google Analytics -->
<script>
  var _gaq = _gaq || [];
_gaq.push(['_setAccount', 'UA-333933-5']);
_gaq.push(['_setCustomVar',
    1,
    'Article"',
    'Sports',
    3
 ]);;
_gaq.push(['_setDomainName', 'arizonasports.com ']);
  _gaq.push(['_setPageGroup', 1, 'Arizona State Basketball Stories']);

  _gaq.push(['_trackPageview']);

  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://' : 'http://') + 'stats.g.doubleclick.net/dc.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();
</script>
<!-- End Google Analytics -->

<!-- Begin comScore Tag -->
<script>
  var _comscore = _comscore || [];
  _comscore.push({ c1: "2", c2: "16033947", c3: "", c4: "http://arizonasports.com/story/1781922/asu-basketballs-rob-edwards-named-pac-12-player-of-the-week/?src=rss?src=rss?src=rss?src=rss" });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>
<noscript>
  <img src="http://b.scorecardresearch.com/p?c1=2&c2=16033947&cv=2.0&cj=1" />
</noscript>
<!-- End comScore Tag -->
<!-- End Analytics -->

</body>
</html>
