<!DOCTYPE html>
<html>
<head>
	<meta http-equiv="content-type" content="text/html; charset=UTF-8">
		<title>Tyvon Branch, John Brown crack NFL.com&#039;s top 101 free agent list</title>
	<meta name="keywords" content="Phoenix Arizona Sports News | Phoenix Breaking Sports News, Home,Arizona Sports Now on 98.7 FM">
		<meta name="author" content="">

	<meta name="verify-v1" content="XrJiQDsWmPaoqGKN0EHKs7ult0rBB0W9zj4cWkAPRVI=" />

	<meta name="viewport" content="width=device-width, maximum-scale=1.0">
	<meta name="apple-itunes-app" content="app-id=719629934">
	<meta property="fb:pages" content="175932795758464" />



			<script type="text/javascript">
		var ajaxurl = 'https://arizonasports.com/wp-admin/admin-ajax.php';
		</script>
		
<!-- This site is optimized with the Yoast SEO plugin v3.7.0 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="Out of the 17 Cardinals that will test free agency, wide receiver John Brown and safety Tyvon Branch made the top 101 free agent list."/>
<meta name="news_keywords" content="arizona cardinals, john brown, tyvon branch, phoenix arizona, arizona coyotes, phoenix suns, arizona diamondbacks, arizona state sun devils, football, baseball, basketball, hockey" />
<link rel="original-source" href="https://arizonasports.com/story/1442553/branch-brown-crack-nfl-coms-top-100-free-agent-list/" />
<meta name="robots" content="noodp"/>
<link rel="canonical" href="https://arizonasports.com/story/1442553/branch-brown-crack-nfl-coms-top-100-free-agent-list/?src=rss" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Tyvon Branch, John Brown crack NFL.com&#039;s top 101 free agent list" />
<meta property="og:description" content="Out of the 17 Cardinals that will test free agency, wide receiver John Brown and safety Tyvon Branch made the top 101 free agent list." />
<meta property="og:url" content="https://arizonasports.com/story/1442553/branch-brown-crack-nfl-coms-top-100-free-agent-list/?src=rss?src=rss" />
<meta property="og:site_name" content="Arizona Sports" />
<meta property="article:publisher" content="https://www.facebook.com/ArizonaSports" />
<meta property="article:tag" content="Arizona Cardinals" />
<meta property="article:tag" content="John Brown" />
<meta property="article:tag" content="Tyvon Branch" />
<meta property="article:section" content="Arizona Cardinals Stories" />
<meta property="article:published_time" content="2018-02-26T14:15:46-07:00" />
<meta property="fb:app_id" content="240396432670516" />
<meta property="og:image" content="https://arizonasports.com/wp-content/uploads/2018/02/brownbranch.jpg" />
<meta property="og:image:width" content="620" />
<meta property="og:image:height" content="370" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Out of the 17 Cardinals that will test free agency, wide receiver John Brown and safety Tyvon Branch made the top 101 free agent list." />
<meta name="twitter:title" content="Tyvon Branch, John Brown crack NFL.com&#039;s top 101 free agent list" />
<meta name="twitter:site" content="@azsports" />
<meta name="twitter:image" content="https://arizonasports.com/wp-content/uploads/2018/02/brownbranch.jpg" />
<meta name="twitter:creator" content="@Tdrake4sports" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//jwpsrv.com' />
<link rel='dns-prefetch' href='//hosted.stats.com' />
<link rel='dns-prefetch' href='//generic.wpengine.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//netdna.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//code.jquery.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Arizona Sports &raquo; Tyvon Branch, John Brown crack NFL.com&#8217;s top 101 free agent list Comments Feed" href="https://arizonasports.com/story/1442553/branch-brown-crack-nfl-coms-top-100-free-agent-list/feed/" />
<link rel='stylesheet' id='3.0-statsshs-css'  href='http://hosted.stats.com/config/shsdefault.css?ver=20170512' type='text/css' media='all' />
<link rel='stylesheet' id='3.0-statsmulti-css'  href='http://hosted.stats.com/config/multidefault.css?ver=20170512' type='text/css' media='all' />
<link rel='stylesheet' id='3.0-main-css'  href='https://generic.wpengine.com/wp-content/themes/mynorthwest/assets/css/web3-main.css?ver=20170402' type='text/css' media='all' />
<link rel='stylesheet' id='3.0-nonhomepage-style-css'  href='https://generic.wpengine.com/wp-content/themes/mynorthwest/assets/css/nonhome.css?ver=20170402' type='text/css' media='all' />
<link rel='stylesheet' id='3.0-dark-css'  href='https://generic.wpengine.com/wp-content/themes/mynorthwest/assets/css/dark.css?ver=20170402' type='text/css' media='all' />
<link rel='stylesheet' id='3.0-arizonasports-css'  href='https://arizonasports.com/wp-content/themes/arizonasports/assets/css/arizonasports.css?ver=20170704' type='text/css' media='all' />
<link rel='stylesheet' id='unity-roboto-slab-css'  href='https://fonts.googleapis.com/css?family=Roboto+Slab%3A400%2C900&#038;ver=4.8.5' type='text/css' media='all' />
<link rel='stylesheet' id='az-polls-css'  href='https://arizonasports.com/wp-content/plugins/az-polls/assets/css/custom.css?ver=1.3' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='http://netdna.bootstrapcdn.com/font-awesome/4.0.3/css/font-awesome.css?ver=4.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='events-css'  href='https://arizonasports.com/wp-content/plugins/tweak-events/assets/css/events.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='jquery-ui-smoothness-css'  href='http://code.jquery.com/ui/1.10.3/themes/smoothness/jquery-ui.css?ver=1.0' type='text/css' media='all' />
<script type='text/javascript' src='https://ajax.googleapis.com/ajax/libs/jquery/1.11.0/jquery.min.js?ver=1.11.0'></script>
<script type='text/javascript' src='https://ajax.googleapis.com/ajax/libs/jqueryui/1.10.4/jquery-ui.min.js?ver=1.10.4'></script>
<script type='text/javascript' src='https://arizonasports.com/wp-content/themes/arizonasports/assets/js/jquery.functions.js?ver=4.4.12'></script>
<script type='text/javascript' src='http://jwpsrv.com/library/hpH9Jq1TEeSPjQp+lcGdIw.js?ver=2.6'></script>
<link rel='https://api.w.org/' href='https://arizonasports.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://arizonasports.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://arizonasports.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='https://arizonasports.com/?p=1442553' />
<link rel="alternate" type="application/json+oembed" href="https://arizonasports.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Farizonasports.com%2Fstory%2F1442553%2Fbranch-brown-crack-nfl-coms-top-100-free-agent-list%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://arizonasports.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Farizonasports.com%2Fstory%2F1442553%2Fbranch-brown-crack-nfl-coms-top-100-free-agent-list%2F&#038;format=xml" />
<link rel="canonical" href="https://arizonasports.com/story/1442553/branch-brown-crack-nfl-coms-top-100-free-agent-list/" />
<!-- BEGIN wp-parsely Plugin Version 1.7 -->
<meta name='wp-parsely_version' id='wp-parsely_version' content='1.7' />
   <script type="application/ld+json">
   {"@context":"http:\/\/schema.org","@type":"NewsArticle","headline":"Tyvon Branch, John Brown crack NFL.com&#8217;s top 101 free agent list","url":"https:\/\/arizonasports.com\/story\/1442553\/branch-brown-crack-nfl-coms-top-100-free-agent-list\/","thumbnailUrl":"https:\/\/arizonasports.com\/wp-content\/uploads\/2018\/02\/brownbranch-150x150.jpg","articleId":"1442553","dateCreated":"2018-02-26T21:15:46Z","articleSection":"Arizona Cardinals Stories","creator":["Tyler Drake"],"keywords":["arizona cardinals","john brown","tyvon branch"]}   </script>
<!-- END wp-parsely Plugin Version 1.7 -->
	<!-- Include google_services.js -->
<script type='text/javascript'>
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
(function() {
var gads = document.createElement('script');
gads.async = true;
gads.type = 'text/javascript';
var useSSL = 'https:' == document.location.protocol;
gads.src = (useSSL ? 'https:' : 'http:') +
'//www.googletagservices.com/tag/js/gpt.js';
var node = document.getElementsByTagName('script')[0];
node.parentNode.insertBefore(gads, node);
})();
</script>
<link rel="amphtml" href="https://arizonasports.com/story/1442553/branch-brown-crack-nfl-coms-top-100-free-agent-list/amp/" />	<!--[if lt IE 9]>
	<script src="https://arizonasports.com/wp-content/themes/arizonasports/assets/js/html5shiv.js"></script>
	<script type="text/javascript" src="https://arizonasports.com/wp-content/themes/arizonasports/assets/js/selectivizr.js"></script>
	<![endif]-->

</head>
<body>
	
        <script>

        var versaTag = {};
        versaTag.id = "5532";
        versaTag.sync = 0;
        versaTag.dispType = "js";
        versaTag.ptcl = "HTTPS";
        versaTag.bsUrl = "bs.serving-sys.com/BurstingPipe";
        //VersaTag activity parameters include all conversion parameters including custom parameters and Predefined parameters. Syntax: "ParamName1":"ParamValue1", "ParamName2":"ParamValue2". ParamValue can be empty.
        versaTag.activityParams = {
        //Predefined parameters:
        "OrderID":"","Session":"","Value":"","productid":"","productinfo":"","Quantity":""
        //Custom parameters:
        };
        //Static retargeting tags parameters. Syntax: "TagID1":"ParamValue1", "TagID2":"ParamValue2". ParamValue can be empty.
        versaTag.retargetParams = {};
        //Dynamic retargeting tags parameters. Syntax: "TagID1":"ParamValue1", "TagID2":"ParamValue2". ParamValue can be empty.
        versaTag.dynamicRetargetParams = {};
        // Third party tags conditional parameters and mapping rule parameters. Syntax: "CondParam1":"ParamValue1", "CondParam2":"ParamValue2". ParamValue can be empty.
        versaTag.conditionalParams = {};
        </script>
        <script id="ebOneTagUrlId" src="https://secure-ds.serving-sys.com/SemiCachedScripts/ebOneTag.js"></script>
        <noscript>
        <iframe src="https://bs.serving-sys.com/BurstingPipe?
        cn=ot&amp;
        onetagid=5532&amp;
        ns=1&amp;
        activityValues=$=[Value]&amp;OrderID=[OrderID]&amp;Session=[Session]&amp;ProductID=[ProductID]&amp;ProductInfo=[ProductInfo]&amp;Quantity=[Quantity]$$&amp;
        retargetingValues=$$$$&amp;
        dynamicRetargetingValues=$$$$&amp;
        acp=$$$$&amp;"
        style="display:none;width:0px;height:0px"></iframe>
        </noscript>
        
<div id="menu" class="screencover">
	<div class="menuicon">
		<a href="#" class="close_menu">x</a>
	</div>
	<ul>
		<li><a href="/">Home</a></li>
		<li><a href="/?s=129"><i class="fa fa-search"></i> Search</a></li>
		<li><a href="/listen-live/">Listen Live</a></li>
		<li><a href="/arizona-sports-podcasts/">Podcasts</a></li>
		<li><a href="/top-stories/" class="topLeftMenu" id="topnews" ref="left_head_nav">Top Stories</a></li>
		<li class="onlymobile"><a href="http://allstar.ktar.com">Rewards</a></li>
		<li class="onlymobile"><a href="http://ktar.com">KTAR.com</a></li>
		<li class="section">Shows</li>
		<li><a href="/doug-wolf/">Doug &amp; Wolf</a></li>
		<li><a href="/the-blitz-with-b-train-and-jurecki/">The Blitz</a></li>
		<li><a href="/bickley-marotta/">Bickley &amp; Marotta</a></li>
		<li><a href="/burns-gambo/">Burns &amp; Gambo</a></li>
		<li><a href="/3/1355312/Arizona-Sports-987">Complete Lineup...</a></li>
		<li class="section">Teams</li>
		<li><a href="/arizona-cardinals/">Cardinals</a></li>
		<li><a href="/phoenix-suns/">Suns</a></li>
		<li><a href="/arizona-diamondbacks/">D-backs</a></li>
		<li><a href="/arizona-coyotes/">Coyotes</a></li>
		<li><a href="/arizona-state-sun-devils/">Sun Devils</a></li>
		<li><a href="/arizona-wildcats/">Wildcats</a></li>
		<li><a href="/arizona-rattlers/">Rattlers</a></li>
		<li><a href="/phoenix-mercury">Mercury</a></li>
		<li><a href="/grand-canyon-lopes/">'Lopes</a></li>
		<li><a href="/northern-arizona-lumberjacks/">Lumberjacks</a></li>
		<li class="section">Special Sections</li>
		<li><a href="/category/character-counts-blogs/">Character Counts</a></li>
    	<li><a href="/haboob-blog/">Haboob Blog</a></li>
    	<li><a href="/category/the-5-blogs/">The 5</a></li>
		<li><a href="/category/threads/">Threads</a></li>
		<li><a href="/cronkite-news-5/">Cronkite Sports</a></li>
	 	<li class="section">98.7 Arizona Sports</li>
    	<li><a href="/Arizona-Sports-987">On-Air Schedule</a></li>
		<li><a href="/category/contests">Rewards</a></li>
		<li><a href="/events/featured">Events</a></li>
    	<li><a href="/starting-five-newsletter-signup/">Newsletter</a></li>
		<li><a href="/text-alerts/">Text Alerts</a></li>
		<li><a href="/the-arizona-sports-98-7-fm-app/">Arizona Sports Apps</a></li>
	    <li><a href="javascript:void()" onclick="popWindow('http://facebook.com/arizonasports')">Facebook</a></li>
	    <li><a href="javascript:void()" onclick="popWindow('http://twitter.com/azsports')">Twitter</a></li>
	    <li><a href="javascript:void()" onclick="popWindow('http://instagram.com/arizsports')">Instagram</a></li>
    </ul>
</div>
<div id="share" class="screencover">
	<div class="menuicon">
		<a href="#" class="close_share">x</a>
	</div>
	<div class="colheader">
		Share this story...
	</div>

						<img width="620" height="370" src="https://arizonasports.com/wp-content/uploads/2018/02/brownbranch-620x370.jpg" class="wide-share wp-post-image" alt="" srcset="https://arizonasports.com/wp-content/uploads/2018/02/brownbranch.jpg 620w, https://arizonasports.com/wp-content/uploads/2018/02/brownbranch-300x179.jpg 300w, https://arizonasports.com/wp-content/uploads/2018/02/brownbranch-120x72.jpg 120w, https://arizonasports.com/wp-content/uploads/2018/02/brownbranch-294x175.jpg 294w, https://arizonasports.com/wp-content/uploads/2018/02/brownbranch-250x149.jpg 250w" sizes="(max-width: 620px) 100vw, 620px" />			
		<ul>
		<li><div>Tyvon Branch, John Brown crack NFL.com&#8217;s top 101 free agent list</div></li>
		<li><a href="javascript:void();" onClick="popShare('http://www.facebook.com/sharer.php?u=https%3A%2F%2Farizonasports.com%2Fstory%2F1442553%2Fbranch-brown-crack-nfl-coms-top-100-free-agent-list%2F&t=https://arizonasports.com | https%3A%2F%2Farizonasports.com%2Fstory%2F1442553%2Fbranch-brown-crack-nfl-coms-top-100-free-agent-list%2F')">Facebook</a></li>
		<li><a href="javascript:void();" onClick="popShare('http://twitter.com/share?text=Tyvon Branch, John Brown crack NFL.com&#8217;s top 101 free agent list&url=https://arizonasports.com/story/1442553/branch-brown-crack-nfl-coms-top-100-free-agent-list/')">Twitter</a></li>
		<li><a href="javascript:void();" onClick="popShare('http://www.linkedin.com/shareArticle?mini=true&amp;url=https%3A%2F%2Farizonasports.com%2Fstory%2F1442553%2Fbranch-brown-crack-nfl-coms-top-100-free-agent-list%2F&amp;title=Tyvon Branch, John Brown crack NFL.com&#8217;s top 101 free agent list&amp;summary=')">LinkedIn</a></li>
		<li><a href="javascript:void();" onClick="popShare('https://plus.google.com/share?url=https%3A%2F%2Farizonasports.com%2Fstory%2F1442553%2Fbranch-brown-crack-nfl-coms-top-100-free-agent-list%2F')">Google +</a></li>
		<li><a href="http://pinterest.com/pin/create/button/?url=https%3A%2F%2Farizonasports.com%2Fstory%2F1442553%2Fbranch-brown-crack-nfl-coms-top-100-free-agent-list%2F&amp;description=Tyvon Branch, John Brown crack NFL.com&#8217;s top 101 free agent list&amp;media=https://arizonasports.com/wp-content/uploads/2018/02/brownbranch.jpg" target="_blank">Pinterest</a></li>
		<li><a href="/email-story/?Subject=The+following+article+has+been+shared+with+you%3A%0A%0A%3Ca+href%3D%22https%3A%2F%2Farizonasports.com%2Fstory%2F1442553%2Fbranch-brown-crack-nfl-coms-top-100-free-agent-list%2F%22%3ETyvon+Branch%2C+John+Brown+crack+NFL.com%26%238217%3Bs+top+101+free+agent+list%3C%2Fa%3E%0A%0Ahttps%3A%2F%2Farizonasports.com%2Fstory%2F1442553%2Fbranch-brown-crack-nfl-coms-top-100-free-agent-list%2F">Email Story</a></li>
	</ul>


</div>


<div id="wrapper">

	<!--OVERLAY WHEN NAVIGATION IS OPEN-->
	<div id="overlay_back"></div>
	<!--OVERLAY WHEN NAVIGATION IS OPEN-->

	<header>
		<!--HEADER-->
		<div class="headerwrapper primary">

			<div id="topnav">
				<div id="topnav_body">
					<ul class="left">
						<li><a href="https://www.facebook.com/ArizonaSports/" target="_blank"><div class="fa fa-facebook-square fonticon"></div> FACEBOOK</a></li>
						<li><a href="https://twitter.com/azsports" target="_blank"><div class="fa fa-twitter-square fonticon"></div> TWITTER</a></li>
						<li><a href="/arizona-sports-daily-insider-signup/"><div class="fa fa-envelope fonticon"></div> EMAIL ALERTS</a></li>
						<li><a href="/the-arizona-sports-98-7-fm-app/"><div class="fa fa-mobile fonticon"></div> GET THE APP</a></li>
					</ul>

					<ul class="right">
																		<li><span class="news-nav-icon"></span><a href="http://ktar.com/">KTAR News</a></li>
						<li><span class="sports-nav-icon"></span><a style="border-bottom: 1px solid red;" href="http://arizonasports.com">Arizona Sports</a></li>
					</ul>
				</div>
			</div>


			<div class="header">
				<div class="menuicon primary">
					<a href="#" class="menu_link"><i class="fa fa-bars" aria-hidden="true"></i></a>
				</div>
									<div class="shareicon primary">
						<a href="#" class="share_link"><i class="fa fa-share" aria-hidden="true"></i></a>
					</div>
								<ul class="upper">
					<li><a href="/top-stories/" class="border">Top Stories</a></li>
					<li><a href="http://allstar.ktar.com" class="border">Rewards</a></li>
					<li><a href="/listen-live" class="border"><i class="fa fa-circle" aria-hidden="true"></i> Listen Live</a></li>
					<!--<li><a href="/watch-live" class="border"><i class="fa fa-circle" aria-hidden="true"></i> Watch Live</a></li>-->
					<li><a href="/category/podcasts" class="border">Podcasts</a></li>
					<!--<li><a href="#" class="border">Scoreboard</a></li>-->
					<li class="farright secondary"><a href="#" class="menu_link borderlight">Menu <i class="fa fa-bars" aria-hidden="true"></i></a></li>
				</ul>
				<a href="/"><img src="https://arizonasports.com/wp-content/themes/arizonasports/assets/logo/ArizonaSports_987fm_RGB_blk-bg.svg"></a>

			</div>
		</div>

	</header>
	<!--HEADER-->
	<div id="mobilespacer"></div>
	<div id="deskspacer"></div>
<div class="farleftcolumn">
<div class="colheader">Latest News</div>
<ul class="morestories">
               <li >
              <a href="https://arizonasports.com/story/1442808/bobby-hurley-fined-10000-conduct-towards-officials-oregon-state/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','https://arizonasports.com/story/1442808/bobby-hurley-fined-10000-conduct-towards-officials-oregon-state/','1']);" class="thumb">
                  <img width="60" height="60" src="https://arizonasports.com/wp-content/uploads/2018/02/ap_888a661d9b4947478e713f4d48bd9bc6-1024x650-1-60x60.jpg" class="thumb wp-post-image" alt=""  />              </a>
              <a href="https://arizonasports.com/story/1442808/bobby-hurley-fined-10000-conduct-towards-officials-oregon-state/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','https://arizonasports.com/story/1442808/bobby-hurley-fined-10000-conduct-towards-officials-oregon-state/','1']);">
                  <span>Kellan Olson<br></span>
                  ASU's Bobby Hurley fined $10,000 for inappropriate conduct toward officials              </a>
		</li>
	         <li >
              <a href="https://arizonasports.com/story/1442780/arizona-coyotes-assign-dauphin-tucson/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','https://arizonasports.com/story/1442780/arizona-coyotes-assign-dauphin-tucson/','1']);" class="thumb">
                  <img width="60" height="60" src="https://arizonasports.com/wp-content/uploads/2018/02/ap_738d1c4e103a4246b6f9b17a571efdba-1024x673-60x60.jpg" class="thumb wp-post-image" alt=""  />              </a>
              <a href="https://arizonasports.com/story/1442780/arizona-coyotes-assign-dauphin-tucson/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','https://arizonasports.com/story/1442780/arizona-coyotes-assign-dauphin-tucson/','1']);">
                  <span>Kellan Olson<br></span>
                  Arizona Coyotes assign Laurent Dauphin to Tucson              </a>
		</li>
	         <li >
              <a href="https://arizonasports.com/story/1442768/robbie-ray-works-quickly-arizona-diamondbacks-spring-training-debut/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','https://arizonasports.com/story/1442768/robbie-ray-works-quickly-arizona-diamondbacks-spring-training-debut/','1']);" class="thumb">
                  <img width="60" height="60" src="https://arizonasports.com/wp-content/uploads/2018/02/ap_4c32d07743f746c5af8309f5d3f7997f-1024x710-1-60x60.jpg" class="thumb wp-post-image" alt=""  />              </a>
              <a href="https://arizonasports.com/story/1442768/robbie-ray-works-quickly-arizona-diamondbacks-spring-training-debut/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','https://arizonasports.com/story/1442768/robbie-ray-works-quickly-arizona-diamondbacks-spring-training-debut/','1']);">
                  <span>Craig Grialou<br></span>
                  D-backs' Robbie Ray works quickly in his Cactus League debut              </a>
		</li>
	         <li >
              <a href="https://arizonasports.com/story/1442748/coyotes-stand-pat-trade-deadline-eye-toward-offseason-moves/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','https://arizonasports.com/story/1442748/coyotes-stand-pat-trade-deadline-eye-toward-offseason-moves/','1']);" class="thumb">
                  <img width="60" height="60" src="https://arizonasports.com/wp-content/uploads/2018/02/chayka-60x60.jpg" class="thumb wp-post-image" alt=""  />              </a>
              <a href="https://arizonasports.com/story/1442748/coyotes-stand-pat-trade-deadline-eye-toward-offseason-moves/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','https://arizonasports.com/story/1442748/coyotes-stand-pat-trade-deadline-eye-toward-offseason-moves/','1']);">
                  <span>Craig Morgan<br></span>
                  Coyotes stand pat at trade deadline with eye toward offseason moves              </a>
		</li>
	         <li >
              <a href="https://arizonasports.com/story/1442718/phoenix-suns-recognize-2000s-teams-players-latest-decade-night/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','https://arizonasports.com/story/1442718/phoenix-suns-recognize-2000s-teams-players-latest-decade-night/','1']);" class="thumb">
                  <img width="60" height="60" src="https://arizonasports.com/wp-content/uploads/2018/02/2000s-suns-60x60.jpg" class="thumb wp-post-image" alt=""  />              </a>
              <a href="https://arizonasports.com/story/1442718/phoenix-suns-recognize-2000s-teams-players-latest-decade-night/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','https://arizonasports.com/story/1442718/phoenix-suns-recognize-2000s-teams-players-latest-decade-night/','1']);">
                  <span>Kynan Marlin<br></span>
                  Phoenix Suns to recognize 2000s teams, players in latest 'Decade Night'              </a>
		</li>
	         <li >
              <a href="https://arizonasports.com/story/1442664/nba-draft-lottery-positioning-2018-suns-kings/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','https://arizonasports.com/story/1442664/nba-draft-lottery-positioning-2018-suns-kings/','1']);" class="thumb">
                  <img width="60" height="60" src="https://arizonasports.com/wp-content/uploads/2018/02/ap_f02ea747b6724d378b750f21a6659199-1024x805-1-60x60.jpg" class="thumb wp-post-image" alt=""  />              </a>
              <a href="https://arizonasports.com/story/1442664/nba-draft-lottery-positioning-2018-suns-kings/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','https://arizonasports.com/story/1442664/nba-draft-lottery-positioning-2018-suns-kings/','1']);">
                  <span>Kellan Olson<br></span>
                  NBA Draft Lottery positioning update: No recent wins for teams at bottom              </a>
		</li>
	         <li >
              <a href="https://arizonasports.com/story/1442699/arizonas-sean-miller-not-team-monday-following-fbi-investigation-scandal/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','https://arizonasports.com/story/1442699/arizonas-sean-miller-not-team-monday-following-fbi-investigation-scandal/','1']);" class="thumb">
                  <img width="60" height="60" src="https://arizonasports.com/wp-content/uploads/2018/02/Sean-Miller370-60x60.jpg" class="thumb wp-post-image" alt=""  />              </a>
              <a href="https://arizonasports.com/story/1442699/arizonas-sean-miller-not-team-monday-following-fbi-investigation-scandal/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','https://arizonasports.com/story/1442699/arizonas-sean-miller-not-team-monday-following-fbi-investigation-scandal/','1']);">
                  <span>Kellan Olson<br></span>
                  Arizona's Sean Miller not with team on Monday amid FBI scandal              </a>
		</li>
	         <li >
              <a href="https://arizonasports.com/story/1442616/2018-nfl-scouting-combine-cardinals-week-ahead/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','https://arizonasports.com/story/1442616/2018-nfl-scouting-combine-cardinals-week-ahead/','1']);" class="thumb">
                  <img width="60" height="60" src="https://arizonasports.com/wp-content/uploads/2018/02/nfl-scouting-combine-generic-60x60.jpg" class="thumb wp-post-image" alt=""  />              </a>
              <a href="https://arizonasports.com/story/1442616/2018-nfl-scouting-combine-cardinals-week-ahead/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','https://arizonasports.com/story/1442616/2018-nfl-scouting-combine-cardinals-week-ahead/','1']);">
                  <span>Arizona Sports<br></span>
                  What to know: Cardinals have huge week ahead at NFL Combine              </a>
		</li>
	         <li >
              <a href="https://arizonasports.com/story/1442673/coyotes-trade-tyler-gaudet-john-ramage-deal-preds-pierre-cedric-labrie/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','https://arizonasports.com/story/1442673/coyotes-trade-tyler-gaudet-john-ramage-deal-preds-pierre-cedric-labrie/','1']);" class="thumb">
                  <img width="60" height="60" src="https://arizonasports.com/wp-content/uploads/2018/02/gaudet-coyotes-cele-60x60.jpg" class="thumb wp-post-image" alt=""  />              </a>
              <a href="https://arizonasports.com/story/1442673/coyotes-trade-tyler-gaudet-john-ramage-deal-preds-pierre-cedric-labrie/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','https://arizonasports.com/story/1442673/coyotes-trade-tyler-gaudet-john-ramage-deal-preds-pierre-cedric-labrie/','1']);">
                  <span>Arizona Sports<br></span>
                  Coyotes trade Tyler Gaudet, John Ramage in a deal with Preds              </a>
		</li>
	         <li >
              <a href="https://arizonasports.com/story/1442643/michael-wright-linda-vollstedt-represent-ua-asu-pac-12-2018-hall-honor/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','https://arizonasports.com/story/1442643/michael-wright-linda-vollstedt-represent-ua-asu-pac-12-2018-hall-honor/','1']);" class="thumb">
                  <img width="60" height="60" src="https://arizonasports.com/wp-content/uploads/2018/02/Wright-60x60.jpg" class="thumb wp-post-image" alt=""  />              </a>
              <a href="https://arizonasports.com/story/1442643/michael-wright-linda-vollstedt-represent-ua-asu-pac-12-2018-hall-honor/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','https://arizonasports.com/story/1442643/michael-wright-linda-vollstedt-represent-ua-asu-pac-12-2018-hall-honor/','1']);">
                  <span>Kynan Marlin<br></span>
                  Wright and Vollstedt represent UA and ASU in Pac-12 Hall of Honor class              </a>
		</li>
	         <li >
              <a href="https://arizonasports.com/story/1442626/arizona-cardinals-picked-dead-last-qb-confidence-ranking/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','https://arizonasports.com/story/1442626/arizona-cardinals-picked-dead-last-qb-confidence-ranking/','1']);" class="thumb">
                  <img width="60" height="60" src="https://arizonasports.com/wp-content/uploads/2018/02/confidence-60x60.jpg" class="thumb wp-post-image" alt=""  />              </a>
              <a href="https://arizonasports.com/story/1442626/arizona-cardinals-picked-dead-last-qb-confidence-ranking/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','https://arizonasports.com/story/1442626/arizona-cardinals-picked-dead-last-qb-confidence-ranking/','1']);">
                  <span>Tyler Drake<br></span>
                  Arizona Cardinals picked last in QB confidence rankings              </a>
		</li>
	         <li class="active">
              <a href="https://arizonasports.com/story/1442553/branch-brown-crack-nfl-coms-top-100-free-agent-list/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','https://arizonasports.com/story/1442553/branch-brown-crack-nfl-coms-top-100-free-agent-list/','1']);" class="thumb">
                  <img width="60" height="60" src="https://arizonasports.com/wp-content/uploads/2018/02/brownbranch-60x60.jpg" class="thumb wp-post-image" alt=""  />              </a>
              <a href="https://arizonasports.com/story/1442553/branch-brown-crack-nfl-coms-top-100-free-agent-list/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','https://arizonasports.com/story/1442553/branch-brown-crack-nfl-coms-top-100-free-agent-list/','1']);">
                  <span>Tyler Drake<br></span>
                  Tyvon Branch, John Brown crack NFL.com's top 101 free agent list              </a>
		</li>
	         <li >
              <a href="https://arizonasports.com/story/1442536/coyotes-trade-for-prospect-jordan-maletta-swap-ryan-kujawinski/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','https://arizonasports.com/story/1442536/coyotes-trade-for-prospect-jordan-maletta-swap-ryan-kujawinski/','1']);" class="thumb">
                  <img width="60" height="60" src="https://arizonasports.com/wp-content/uploads/2018/02/jordan-maletta-trade-coyotes-60x60.jpg" class="thumb wp-post-image" alt=""  />              </a>
              <a href="https://arizonasports.com/story/1442536/coyotes-trade-for-prospect-jordan-maletta-swap-ryan-kujawinski/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','https://arizonasports.com/story/1442536/coyotes-trade-for-prospect-jordan-maletta-swap-ryan-kujawinski/','1']);">
                  <span>Arizona Sports<br></span>
                  Coyotes acquire Jordan Maletta, Carter Camper in trade with Blue Jackets              </a>
		</li>
	         <li >
              <a href="https://arizonasports.com/story/1442505/ncaa-tournament-seeding-brackets-asu-took-hit-worst-loss-year/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','https://arizonasports.com/story/1442505/ncaa-tournament-seeding-brackets-asu-took-hit-worst-loss-year/','1']);" class="thumb">
                  <img width="60" height="60" src="https://arizonasports.com/wp-content/uploads/2018/02/bobby-hurley-oregon-state-loss-60x60.jpg" class="thumb wp-post-image" alt=""  />              </a>
              <a href="https://arizonasports.com/story/1442505/ncaa-tournament-seeding-brackets-asu-took-hit-worst-loss-year/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','https://arizonasports.com/story/1442505/ncaa-tournament-seeding-brackets-asu-took-hit-worst-loss-year/','1']);">
                  <span>Kevin Zimmerman<br></span>
                  ASU took NCAA tournament seeding hit with loss to Oregon State              </a>
		</li>
	         <li >
              <a href="https://arizonasports.com/story/1442471/college-basketball-rankings-arizona-ap-poll-falls-amid-fbi-scandal/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','https://arizonasports.com/story/1442471/college-basketball-rankings-arizona-ap-poll-falls-amid-fbi-scandal/','1']);" class="thumb">
                  <img width="60" height="60" src="https://arizonasports.com/wp-content/uploads/2018/02/arizona-oregon-college-basketball-rankings-60x60.jpg" class="thumb wp-post-image" alt=""  />              </a>
              <a href="https://arizonasports.com/story/1442471/college-basketball-rankings-arizona-ap-poll-falls-amid-fbi-scandal/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','https://arizonasports.com/story/1442471/college-basketball-rankings-arizona-ap-poll-falls-amid-fbi-scandal/','1']);">
                  <span>Arizona Sports<br></span>
                  Amid questions from FBI investigation, Arizona falls in AP Poll              </a>
		</li>
	         <li >
              <a href="https://arizonasports.com/story/1442446/red-sox-finally-officially-introduce-slugger-j-d-martinez/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','https://arizonasports.com/story/1442446/red-sox-finally-officially-introduce-slugger-j-d-martinez/','1']);" class="thumb">
                  <img width="60" height="60" src="https://arizonasports.com/wp-content/uploads/2018/02/JDMartinez_MA4-60x60.jpg" class="thumb wp-post-image" alt=""  />              </a>
              <a href="https://arizonasports.com/story/1442446/red-sox-finally-officially-introduce-slugger-j-d-martinez/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','https://arizonasports.com/story/1442446/red-sox-finally-officially-introduce-slugger-j-d-martinez/','1']);">
                  <span>Vince Marotta<br></span>
                  Red Sox finally officially introduce slugger J.D. Martinez              </a>
		</li>
	         <li >
              <a href="https://arizonasports.com/story/1365441/arizona-cardinals-2018-mock-draft-tracker/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','https://arizonasports.com/story/1365441/arizona-cardinals-2018-mock-draft-tracker/','1']);" class="thumb">
                  <img width="60" height="60" src="https://arizonasports.com/wp-content/uploads/2018/01/mocktrackerimage2-60x60.jpg" class="thumb wp-post-image" alt=""  />              </a>
              <a href="https://arizonasports.com/story/1365441/arizona-cardinals-2018-mock-draft-tracker/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','https://arizonasports.com/story/1365441/arizona-cardinals-2018-mock-draft-tracker/','1']);">
                  <span>Arizona Sports<br></span>
                  Arizona Cardinals 2018 Mock Draft Tracker              </a>
		</li>
	         <li >
              <a href="https://arizonasports.com/story/1442320/darcy-kuemper-turns-in-strong-showing-despite-coyotes-loss-to-canucks/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','https://arizonasports.com/story/1442320/darcy-kuemper-turns-in-strong-showing-despite-coyotes-loss-to-canucks/','1']);" class="thumb">
                  <img width="60" height="60" src="https://arizonasports.com/wp-content/uploads/2018/02/darcy-kuemper-debut-coyotes-60x60.jpg" class="thumb wp-post-image" alt=""  />              </a>
              <a href="https://arizonasports.com/story/1442320/darcy-kuemper-turns-in-strong-showing-despite-coyotes-loss-to-canucks/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','https://arizonasports.com/story/1442320/darcy-kuemper-turns-in-strong-showing-despite-coyotes-loss-to-canucks/','1']);">
                  <span>Craig Morgan<br></span>
                  Kuemper turns in strong showing despite Coyotes' loss to Canucks              </a>
		</li>
	         <li >
              <a href="https://arizonasports.com/story/1442318/coyotes-canucks-special-teams-goals-loss/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','https://arizonasports.com/story/1442318/coyotes-canucks-special-teams-goals-loss/','1']);" class="thumb">
                  <img width="60" height="60" src="https://arizonasports.com/wp-content/uploads/2018/02/canucks-coyotes-225-60x60.jpg" class="thumb wp-post-image" alt=""  />              </a>
              <a href="https://arizonasports.com/story/1442318/coyotes-canucks-special-teams-goals-loss/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','https://arizonasports.com/story/1442318/coyotes-canucks-special-teams-goals-loss/','1']);">
                  <span>Matt Layman<br></span>
                  Special teams, late goals hurt Coyotes in loss to Canucks              </a>
		</li>
	         <li >
              <a href="https://arizonasports.com/story/1442329/iowa-jordan-bohannon-misses-free-throw-tribute-hawkeye-chris-street/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','https://arizonasports.com/story/1442329/iowa-jordan-bohannon-misses-free-throw-tribute-hawkeye-chris-street/','1']);" class="thumb">
                  <img width="60" height="60" src="https://arizonasports.com/wp-content/uploads/2018/02/jordan-bohannon-ft-60x60.jpg" class="thumb wp-post-image" alt=""  />              </a>
              <a href="https://arizonasports.com/story/1442329/iowa-jordan-bohannon-misses-free-throw-tribute-hawkeye-chris-street/" onclick="_gaq.push(['_trackEvent','Left ArizonaSports Nav','https://arizonasports.com/story/1442329/iowa-jordan-bohannon-misses-free-throw-tribute-hawkeye-chris-street/','1']);">
                  <span>Character Counts<br></span>
                  Iowa guard misses free throw as tribute to late record-holder              </a>
		</li>
	</ul>
</div>
<div id="wrapper">
	<div id="mainbody">
					<div style="z-index:-1;" id="adtop" class="primaryad">
      	<script type='text/javascript'>
googletag.cmd.push(function() {
	//Nick, I’m the happiest if you use me for the default ad mapping
    var mappingDefault = googletag.sizeMapping().
    // Same width as mapping above, more available height
    addSize([320, 400], [300, 250]).
    // Landscape tablet
    addSize([750, 200], [[300, 250],[300,600]]).build();

	var mappingDesktop = googletag.sizeMapping().
	// Same width as mapping above, more available height
	addSize([320, 400], [0, 0]).
	// Landscape tablet
	addSize([750, 200], [300, 250]).build();

    var mappingMobile = googletag.sizeMapping().
    // mobile ad
    addSize([320, 400], [300, 250]).
    // hide tablet or desktop ad
    addSize([750, 200], [0,0]).build();
googletag.defineSlot('/1034751/azsports_spanner', [[970,90]], "acm-ad-tag-azsports_spanner-5a94b9352a4d89.95907897").defineSizeMapping(mappingDefault).addService(googletag.pubads()).setCollapseEmptyDiv(true,true);
googletag.pubads().collapseEmptyDivs();
googletag.enableServices();
});
</script>

<div id='acm-ad-tag-azsports_spanner-5a94b9352a4d89.95907897' class='azsports_spanner spanner'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('acm-ad-tag-azsports_spanner-5a94b9352a4d89.95907897'); });
</script>
</div>
		</div>
    
<!-- Content -->
<article itemscope itemtype="http://schema.org/Article" class="pad">
            <div id="holder">
            <!--HEADLINE AND ART-->
            <div class="lead primary">
                                                                
                                                
                <div class="category"><a href="https://arizonasports.com/category/cardinals-stories/">Arizona Cardinals Stories</a></div>
                <h1 itemprop="name headline">Tyvon Branch, John Brown crack NFL.com&#8217;s top 101 free agent list</h1>
                <div class="byline">
                    <div class="button right">
                        <a href="#" class="share_link">Share &nbsp; <i class="fa fa-share" aria-hidden="true"></i></a>
                    </div>

                    
                        
                             By <a href="https://arizonasports.com/story/author/stdrake/" style="font-weight:500;"><span itemprop="author">Tyler Drake</span></a><br> 
                            <span class="small"><span itemprop="datePublished" content="February 26, 2018 2:15 pm">February 26, 2018 at 2:15 pm</span></span>

                        
                    
                </div>
            </div>
            <!--HEADLINE AND ART-->

            <!--STORY-->
            <div class="story">
                <!-- Image Block -->
                                                                                        <div id="horiz_photo" style="display:none;">
                                <img class="storyimg" itemprop="image" src="https://arizonasports.com/wp-content/uploads/2018/02/brownbranch.jpg" />
                                <div class="caption"></div>
                            </div>

                            
                                                            

                <p>In a latest ranking of the top free agents in the NFL, two Arizona Cardinals found themselves right in the mix.</p>
<p>With free agency right around corner, <a href="http://www.nfl.com/news/story/0ap3000000917412/article/top-101-nfl-free-agents-of-2018-kirk-cousins-tops-the-board" target="_blank" rel="noopener">NFL.com&#8217;s Gregg Rosenthal and Chris Wesseling</a> broke down the top 101 free agents available, highlighting Cardinals wide receiver John Brown and safety Tyvon Branch.</p>
<p>With 17 Cardinals set to test free agency, Brown and Branch were the only two to make the cut, coming in at No. 52 and No. 72, respectively.</p><div style="text-align: center;"><script type='text/javascript'>
googletag.cmd.push(function() {
	//Nick, I’m the happiest if you use me for the default ad mapping
    var mappingDefault = googletag.sizeMapping().
    // Same width as mapping above, more available height
    addSize([320, 400], [300, 250]).
    // Landscape tablet
    addSize([750, 200], [[300, 250],[300,600]]).build();

	var mappingDesktop = googletag.sizeMapping().
	// Same width as mapping above, more available height
	addSize([320, 400], [0, 0]).
	// Landscape tablet
	addSize([750, 200], [300, 250]).build();

    var mappingMobile = googletag.sizeMapping().
    // mobile ad
    addSize([320, 400], [300, 250]).
    // hide tablet or desktop ad
    addSize([750, 200], [0,0]).build();
googletag.defineSlot('/1034751/sports_only_ads', [[300,250]], "acm-ad-tag-sports_only_ads-5a94b9352ecbc6.89442153").defineSizeMapping(mappingMobile).addService(googletag.pubads()).setCollapseEmptyDiv(true,true);
googletag.pubads().collapseEmptyDivs();
googletag.enableServices();
});
</script>

<div id='acm-ad-tag-sports_only_ads-5a94b9352ecbc6.89442153' class='sports_only_ads mobile_300x250'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('acm-ad-tag-sports_only_ads-5a94b9352ecbc6.89442153'); });
</script>
</div>
</div></p>
<p><strong>WR John Brown &#8211; No. 52</strong></p>
<div id="attachment_1365446" style="width: 630px" class="wp-caption alignnone"><a href="http://arizonasports.com/wp-content/uploads/2018/01/AP_246086018128.jpg"><img class="size-full wp-image-1365446" src="https://arizonasports.com/wp-content/uploads/2018/01/AP_246086018128.jpg" alt="" width="620" height="370" srcset="https://arizonasports.com/wp-content/uploads/2018/01/AP_246086018128.jpg 620w, https://arizonasports.com/wp-content/uploads/2018/01/AP_246086018128.jpg-300x179.png 300w, https://arizonasports.com/wp-content/uploads/2018/01/AP_246086018128-120x72.jpg 120w, https://arizonasports.com/wp-content/uploads/2018/01/AP_246086018128-294x175.jpg 294w, https://arizonasports.com/wp-content/uploads/2018/01/AP_246086018128.jpg-250x149.png 250w" sizes="(max-width: 620px) 100vw, 620px" /></a><p class="wp-caption-text">(AP Photo/John Cordes)</p></div>
<blockquote><p>Like so many intriguing free agents, Brown has a history of injuries that makes him a boom-or-bust option. He hasn&#8217;t been quite right since his 1,000-yard season in 2015.</p></blockquote>
<p>Brown saw his production increase from 2014 to 2015, but has since seen a big dropoff in almost every receiving category.</p>
<p>Thanks in part to injuries and the quarterback situation, Brown has&#8217;t been able to replicate his 65-catch and 1,003-yard effort from 2015. Last season, he failed to reach 300 yards and played in just 10 games for the Cardinals.</p>
<p>When he did get the ball he averaged 14.2 yards a catch, but saw a career-low in targets with 56 &#8212; down 45 from 2015.</p>
<p>His total yards ranked him 147th in the NFL among pass catchers &#8212; one spot lower than Jacksonville Jaguars running back Leonard Fournette and tied with Atlanta Falcons running back Tevin Coleman.</p>
<p>His best game of the season came in Week 6, where he caught three balls for 63 yards and a 31-yard touchdown.</p>
<p><strong>S Tyvon Branch &#8211; No. 72</strong></p>
<div id="attachment_1270257" style="width: 630px" class="wp-caption alignnone"><a href="http://arizonasports.com/wp-content/uploads/2017/10/ertz_cardinals.jpg"><img class="size-full wp-image-1270257" src="https://arizonasports.com/wp-content/uploads/2017/10/ertz_cardinals.jpg" alt="" width="620" height="370" srcset="https://arizonasports.com/wp-content/uploads/2017/10/ertz_cardinals.jpg 620w, https://arizonasports.com/wp-content/uploads/2017/10/ertz_cardinals-300x179.jpg 300w, https://arizonasports.com/wp-content/uploads/2017/10/ertz_cardinals-120x72.jpg 120w, https://arizonasports.com/wp-content/uploads/2017/10/ertz_cardinals-294x175.jpg 294w, https://arizonasports.com/wp-content/uploads/2017/10/ertz_cardinals.jpg-250x149.png 250w" sizes="(max-width: 620px) 100vw, 620px" /></a><p class="wp-caption-text">(AP Photo/Michael Perez)</p></div>
<blockquote><p>Defensive coordinator James Bettcher knew just how to use Branch&#8217;s ability to cover tight ends. Don&#8217;t be surprised if Branch follows Bettcher to Big Blue.</p></blockquote>
<p>Like Brown, the injury bug hampered Branch&#8217;s availability as the 10-year vet only played in nine games for Arizona after playing in just six in 2016.</p>
<div class="relatedLinks alignleft"><div class="colheader">Related Links</div><div><ul class="head_list"><li><a href="http://arizonasports.com/story/1435671/espn-rates-the-cardinals-chances-of-landing-each-qb/">ESPN rates the Cardinals’ chances of landing each QB</a></li><li><a href="http://arizonasports.com/story/1407279/list-arizona-cardinals-free-agents-2018-unrestricted-restricted/">A list of the Cardinals’ unrestricted, restricted and exclusive free agents</a></li></ul></div></div>
<p>But when he was on the field, he made the snaps count, registering at least seven tackles in the first five games and either leading the team or recording the second-most tackles in all but two games in which he played.</p>
<p>In Week 3&#8217;s 28-17 loss to the Dallas Cowboys, Branch had his best performance of the season, making a game-leading 12 tackles. The next closest Cardinal was Tyrann Mathieu with four tackles.</p>
<p>Looking at the rest of the free agents on the list, much-talked about quarterback Kirk Cousins &#8212; who has been the subject of conversation in Arizona &#8212; sits atop the rankings, while quarterback Jay Cutler rounds out the list at No. 101.</p>
<p>The free agent frenzy officially begins March 14.</p>
<p><a class="twitter-follow-button" href="https://twitter.com/Tdrake4sports" data-show-count="false">Follow @Tdrake4sports</a><script async src="//platform.twitter.com/widgets.js" charset="utf-8"></script></p>
                
                <div class="lowertools">
                    <ul>
                        
                                                    <li><a href="?show=comments#comments" onclick="_gaq.push(['_trackEvent','ArizonaSports Article','https://arizonasports.com/story/1442553/branch-brown-crack-nfl-coms-top-100-free-agent-list/','Comments']);"><span class="disqus-comment-count" data-disqus-url="https://arizonasports.com/story/1442553/branch-brown-crack-nfl-coms-top-100-free-agent-list/"></span> Comments &nbsp; <i class="fa fa-comments" aria-hidden="true"></i></a></li>
                                                <li><a href="#" class="share_link"> Share &nbsp; <i class="fa fa-share" aria-hidden="true"></i></a></li>
                    </ul>
                </div>

                <div style="clear:both;"></div>
                <div id="article_footer">

                    <div class="bottom_cluster">
                                                    
<div class="lowerstories">
    <div class="colheader">
                    Top Stories            </div>
    <ul>
            <li>
            <a href="http://arizonasports.com/story/1442748/coyotes-stand-pat-trade-deadline-eye-toward-offseason-moves/" onclick="_gaq.push(['_trackEvent','ArizonaSports Article','http://arizonasports.com/story/1442748/coyotes-stand-pat-trade-deadline-eye-toward-offseason-moves/','Top_Stories_1']);">
                <img width="250" height="149" src="https://arizonasports.com/wp-content/uploads/2018/02/chayka.jpg-250x149.png" class="attachment-post_list size-post_list" alt="" srcset="https://arizonasports.com/wp-content/uploads/2018/02/chayka.jpg-250x149.png 250w, https://arizonasports.com/wp-content/uploads/2018/02/chayka.jpg-300x179.png 300w, https://arizonasports.com/wp-content/uploads/2018/02/chayka.jpg 620w, https://arizonasports.com/wp-content/uploads/2018/02/chayka-120x72.jpg 120w, https://arizonasports.com/wp-content/uploads/2018/02/chayka-294x175.jpg 294w" sizes="(max-width: 250px) 100vw, 250px" />            </a>
            <a href="http://arizonasports.com/story/1442748/coyotes-stand-pat-trade-deadline-eye-toward-offseason-moves/" class="subline" onclick="_gaq.push(['_trackEvent','ArizonaSports Article','http://arizonasports.com/story/1442748/coyotes-stand-pat-trade-deadline-eye-toward-offseason-moves/','Top_Stories_1']);">
                <b>Coyotes stand pat at trade deadline with eye toward offseason moves</b>
            </a>
        </li>
	                            					<li style="position:relative;" >
		
		<a href="http://arizonasports.com/story/1442626/arizona-cardinals-picked-dead-last-qb-confidence-ranking/" onclick="_gaq.push(['_trackEvent','ArizonaSports Article','http://arizonasports.com/story/1442626/arizona-cardinals-picked-dead-last-qb-confidence-ranking/','Top_Stories_2']);">
			<!--<img src="https://arizonasports.com/wp-content/uploads/2018/02/confidence.jpg-300x179.png" alt="Arizona Cardinals picked last in QB confidence rankings" width="250">-->
			<img width="250" height="149" src="https://arizonasports.com/wp-content/uploads/2018/02/confidence.jpg-250x149.png" class="attachment-post_list size-post_list" alt="" srcset="https://arizonasports.com/wp-content/uploads/2018/02/confidence.jpg-250x149.png 250w, https://arizonasports.com/wp-content/uploads/2018/02/confidence.jpg-300x179.png 300w, https://arizonasports.com/wp-content/uploads/2018/02/confidence.jpg 620w, https://arizonasports.com/wp-content/uploads/2018/02/confidence-120x72.jpg 120w, https://arizonasports.com/wp-content/uploads/2018/02/confidence-294x175.jpg 294w" sizes="(max-width: 250px) 100vw, 250px" />		</a>
		<a href="http://arizonasports.com/story/1442626/arizona-cardinals-picked-dead-last-qb-confidence-ranking/" class="subline" onclick="_gaq.push(['_trackEvent','ArizonaSports Article','http://arizonasports.com/story/1442626/arizona-cardinals-picked-dead-last-qb-confidence-ranking/','Top_Stories_2']);">
			<b>Arizona Cardinals picked last in QB confidence rankings</b>
		</a>

	</li>
						<li style="position:relative;" >
		
		<a href="http://arizonasports.com/story/1442673/coyotes-trade-tyler-gaudet-john-ramage-deal-preds-pierre-cedric-labrie/" onclick="_gaq.push(['_trackEvent','ArizonaSports Article','http://arizonasports.com/story/1442673/coyotes-trade-tyler-gaudet-john-ramage-deal-preds-pierre-cedric-labrie/','Top_Stories_3']);">
			<!--<img src="https://arizonasports.com/wp-content/uploads/2018/02/gaudet-coyotes-cele.jpg-300x179.png" alt="Coyotes trade Gaudet, Ramage in a deal with Preds" width="250">-->
			<img width="250" height="149" src="https://arizonasports.com/wp-content/uploads/2018/02/gaudet-coyotes-cele.jpg-250x149.png" class="attachment-post_list size-post_list" alt="" srcset="https://arizonasports.com/wp-content/uploads/2018/02/gaudet-coyotes-cele.jpg-250x149.png 250w, https://arizonasports.com/wp-content/uploads/2018/02/gaudet-coyotes-cele.jpg-300x179.png 300w, https://arizonasports.com/wp-content/uploads/2018/02/gaudet-coyotes-cele.jpg 620w, https://arizonasports.com/wp-content/uploads/2018/02/gaudet-coyotes-cele-120x72.jpg 120w, https://arizonasports.com/wp-content/uploads/2018/02/gaudet-coyotes-cele-294x175.jpg 294w" sizes="(max-width: 250px) 100vw, 250px" />		</a>
		<a href="http://arizonasports.com/story/1442673/coyotes-trade-tyler-gaudet-john-ramage-deal-preds-pierre-cedric-labrie/" class="subline" onclick="_gaq.push(['_trackEvent','ArizonaSports Article','http://arizonasports.com/story/1442673/coyotes-trade-tyler-gaudet-john-ramage-deal-preds-pierre-cedric-labrie/','Top_Stories_3']);">
			<b>Coyotes trade Gaudet, Ramage in a deal with Preds</b>
		</a>

	</li>
			
</ul>

</div>                                            </div>
                    
                                                                
                </div>


            </div>
            <!--STORY-->

            <!--RIGHT COLUMN...BELOW STORY ON MOBILE-->
            <div class="rightcolumn">
        <div style="margin-bottom: 30px; text-align:center;">
      <script type='text/javascript'>
googletag.cmd.push(function() {
	//Nick, I’m the happiest if you use me for the default ad mapping
    var mappingDefault = googletag.sizeMapping().
    // Same width as mapping above, more available height
    addSize([320, 400], [300, 250]).
    // Landscape tablet
    addSize([750, 200], [[300, 250],[300,600]]).build();

	var mappingDesktop = googletag.sizeMapping().
	// Same width as mapping above, more available height
	addSize([320, 400], [0, 0]).
	// Landscape tablet
	addSize([750, 200], [300, 250]).build();

    var mappingMobile = googletag.sizeMapping().
    // mobile ad
    addSize([320, 400], [300, 250]).
    // hide tablet or desktop ad
    addSize([750, 200], [0,0]).build();
googletag.defineSlot('/1034751/sports_only_ads', [[300,250], [300,600]], "acm-ad-tag-sports_only_ads-5a94b9353d1972.80422111").defineSizeMapping(mappingDefault).addService(googletag.pubads()).setCollapseEmptyDiv(true,true);
googletag.pubads().collapseEmptyDivs();
googletag.enableServices();
});
</script>

<div id='acm-ad-tag-sports_only_ads-5a94b9353d1972.80422111' class='sports_only_ads right_300x250_or_300x600'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('acm-ad-tag-sports_only_ads-5a94b9353d1972.80422111'); });
</script>
</div>
    </div>
    <div class="subleads">

    <div class="colheader">
            Most Popular          </div>
    
    <ul class="head_list">

              <li><a href="https://arizonasports.com/story/1442699/arizonas-sean-miller-not-team-monday-following-fbi-investigation-scandal/">Arizona&#39;s Sean Miller not with team on Monday amid FBI scandal</a></li>
              <li><a href="https://arizonasports.com/story/1442536/coyotes-trade-for-prospect-jordan-maletta-swap-ryan-kujawinski/">Coyotes acquire Jordan Maletta, Carter Camper in trade with Blue Jackets</a></li>
              <li><a href="https://arizonasports.com/story/1442471/college-basketball-rankings-arizona-ap-poll-falls-amid-fbi-scandal/">Amid questions from FBI investigation, Arizona falls in AP Poll</a></li>
      
    </ul>

</div>
            <div class="bottom_cluster">
          <div class="colheader">Cardinals Audio</div>
          <div class="heads_right_with_art">
        <ul>
                              <li class="first">
                                    <a href="/player/?a=340578" class="thumb"><img src="https://arizonasports.com/wp-content/uploads/2017/04/Header-Bickley-Marotta-960x600_20170426.jpg"></a>
            
            <a href="/player/?a=340578">
                                        <b style="color:#000">Hardware</b>
                    
                                        Monday February 26                    
                                        <div class="highlight">
                     See who won the "Calculated Risk" award, the "Oh No!" award + more.                    </div>
                                    </a>
            </li>
                              <li >
                                    <a href="/player/?a=340480" class="thumb"><img src="https://arizonasports.com/wp-content/uploads/2017/04/Header-Bickley-Marotta-960x600_20170426.jpg"></a>
            
            <a href="/player/?a=340480">
                                        <b style="color:#000">Vinny Joe Trivia - 1970s Sports</b>
                    
                                        Thursday February 22                    
                                        <div class="highlight">
                     Vince takes on Ricky Cobb of Super 70s Sports in 1970s sports trivia.                    </div>
                                    </a>
            </li>
                              <li >
                                    <a href="/player/?a=340477" class="thumb"><img src="https://arizonasports.com/wp-content/uploads/2017/04/Header-Bickley-Marotta-960x600_20170426.jpg"></a>
            
            <a href="/player/?a=340477">
                                        <b style="color:#000">Mike Sando, ESPN NFL Insider</b>
                    
                                        Thursday February 22                    
                                        <div class="highlight">
                     Sando talks Cardinals QB search and where Kirk Cousins might go.                    </div>
                                    </a>
            </li>
                              <li >
                                    <a href="/player/?a=340468" class="thumb"><img src="https://arizonasports.com/wp-content/uploads/2017/07/Header-The-Blitz-960x600-2017.07.jpg"></a>
            
            <a href="/player/?a=340468">
                                        <b style="color:#000">Big Deal...or No Deal?</b>
                    
                                        Thursday February 22                    
                                        <div class="highlight">
                     Andrew Luck is throwing, new rules and a chicken shortage. Find out if any of these subjects are a B                    </div>
                                    </a>
            </li>
                              <li >
                                    <a href="/player/?a=340467" class="thumb"><img src="https://arizonasports.com/wp-content/uploads/2017/07/Header-The-Blitz-960x600-2017.07.jpg"></a>
            
            <a href="/player/?a=340467">
                                        <b style="color:#000">Jude LaCava, Fox 10 Sports</b>
                    
                                        Thursday February 22                    
                                        <div class="highlight">
                     Jude LaCava thinks that this Diamondbacks front office is the most prepared front office we've seen                     </div>
                                    </a>
            </li>
                </ul>
         </div>
 </div>
    </div>
            <!--RIGHT COLUMN...BELOW STORY ON MOBILE-->


            <!--STORY HOLDER-->

        </div>
    </article> <!-- End Content -->

	</div>
</div>

<div id="bottom_mobile_heads">
</div>
<div id="footwrapper">
	<div id="footbody" class="primary">
		<footer>

		<a href="/"><img src="https://arizonasports.com/wp-content/themes/arizonasports/assets/logo/ArizonaSports_4C_blk-bg.svg" alt="Arizona Sports Now On 98.7 FM" style="width:300px;border:none;"></a><br>
		<span>Phoenix, Arizona, USA</span>

		<ul class="footlisten">
			<li>
				<div style="float:left;">On the radio:</div><div style="float:right;"><a href="/listen-live/">98.7 FM</a></div>
			</li>
			<li>
				<div style="float:left;">Online:</div><div style="float:right;"><a href="/">ArizonaSports.com</a></div>
			</li>
			<li>
				<div style="float:left;">On Your Phone:</div><div style="float:right;"><a href="/the-arizona-sports-98-7-fm-app/">98.7 Arizona Sports Apps</a></div>
			</li>
			<li>
				<div style="float:left;">On Demand:</div><div style="float:right;"><a href="/arizona-sports-podcasts/">98.7 Arizona Sports Podcasts</a></div>
			</li>
			<li>
				<div style="float:left;">More:</div><div style="float:right;"><a href="https://itunes.apple.com/" target="new">iTunes</a>, <a href="http://tunein.com/radio/Arizona-Sports-620-s55378/" target="new">TuneIn</a>, <a href="http://stitcher.com" target="new">Stitcher</a></div>
			</li>
			<li>
				<div style="float:left;">Call In:</div><div style="float:right;"><a href="tel:602.274.6200">602.274.6200</a></div>
			</li>
			<li>
				<div style="float:left;">Text In:</div><div style="float:right;"><a href="/text-alerts/">620620</a></div>
			</li>
		</ul>



			<ul class="footlinks">
				<li><a href="/contact-us/">Contact Us</a></li>
				<li>
					 <a href="http://arizonasports.com/wp-content/uploads/2016/03/General-Contest-Rules1.pdf">Contest Rules</a>
				</li>
				<li><a href="http://facebook.com/arizonasports">Follow on Facebook</a></li>
				<li><a href="http://twitter.com/azsports">Follow on Twitter</a></li>
				<li><a href="/98/1602357/Sign-Up">Email Alerts</a></li>
                <!--<li><a href="#">Site Map</a></li>
                <li><a href="http://jobs.bonnint.net/">Advertise With Us</a></li>-->
                <li><a href="http://bonnevillephoenix.applicantpro.com/jobs/">Employment</a></li>
            </ul>


			<div class="copyright">© 2018 Bonneville International. <a href="/2011/01/03/terms-of-use/">Terms of Use</a> and <a href="/2011/01/03/privacy-statement/">Privacy Policy</a>. All rights reserved.<br><a href="http://ktar.com/wp-content/uploads/2017/05/Annual-EEO-Public-File-Report-2017.pdf">EEO Public File Report</a>.  <a href="/story/979712/copyright-info/">Copyright Infringement</a>  <br /> FCC Public File: <a href="https://publicfiles.fcc.gov/fm-profile/kmvp-fm" target="_blank">KMVP-FM</a>  &#149; <a href="https://publicfiles.fcc.gov/am-profile/ktar" target="_blank">KTAR-AM</a> &#149; <a href="https://publicfiles.fcc.gov/am-profile/kmvp" target="_blank">KMVP-AM</a> | FCC Station Representative: Ashley Mannion &#149; <a href="mailto:amannion@bonneville.com?subject=Need Assist with FCC Public File">amannion@bonneville.com</a> &#149; 602.200.2638 </div>



		</footer>
	</div>
</div>
<script id="dsq-count-scr" src="//arizonasports.disqus.com/count.js" async></script>

<!-- START Parse.ly Include: Standard -->
<div id="parsely-root" style="display: none">
  <div id="parsely-cfg" data-parsely-site="arizonasports.com"></div>
</div>
<script>
(function(s, p, d) {
  var h=d.location.protocol, i=p+"-"+s,
      e=d.getElementById(i), r=d.getElementById(p+"-root"),
      u=h==="https:"?"d1z2jf7jlzjs58.cloudfront.net"
      :"static."+p+".com";
  if (e) return;
  e = d.createElement(s); e.id = i; e.async = true;
  e.src = h+"//"+u+"/p.js"; r.appendChild(e);
})("script", "parsely", document);
</script>
<!-- END Parse.ly Include: Standard -->
<script type='text/javascript' src='https://arizonasports.com/wp-content/plugins/ad-code-timing/assets/js/mobile-detect.min.js?ver=1.0'></script>
<script type='text/javascript' src='https://arizonasports.com/wp-content/plugins/ad-code-timing/assets/js/jquery.cookie.js?ver=1.0'></script>
<script type='text/javascript' src='https://arizonasports.com/wp-content/plugins/ad-code-timing/assets/js/takeover.js?ver=1.1'></script>
<script type='text/javascript'>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</script>
<script type='text/javascript' src='https://arizonasports.com/wp-content/plugins/quick-pagepost-redirect-plugin/js/qppr_frontend_script.min.js?ver=5.1.5'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var share = {"url":"https:\/\/arizonasports.com\/story\/1442553\/branch-brown-crack-nfl-coms-top-100-free-agent-list\/"};
/* ]]> */
</script>
<script type='text/javascript' src='https://arizonasports.com/wp-content/themes/arizonasports/assets/js/sharecounts.js?ver=1.0'></script>
<script type='text/javascript' src='https://arizonasports.com/wp-content/plugins/az-polls/assets/js/polls.js?ver=1.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var data = {"ajax_url":"https:\/\/arizonasports.com\/wp-admin\/admin-ajax.php","a_value":"10"};
var data = {"ajax_url":"https:\/\/arizonasports.com\/wp-admin\/admin-ajax.php","a_value":"10"};
/* ]]> */
</script>
<script type='text/javascript' src='https://arizonasports.com/wp-content/plugins/tweak-events/assets/js/plusdate.js?ver=1.0'></script>
<script type='text/javascript' src='https://arizonasports.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://arizonasports.com/wp-includes/js/jquery/ui/datepicker.min.js?ver=1.11.4'></script>
<script type='text/javascript'>
jQuery(document).ready(function(jQuery){jQuery.datepicker.setDefaults({"closeText":"Close","currentText":"Today","monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Previous","dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"dateFormat":"MM d, yy","firstDay":1,"isRTL":false});});
</script>
<script type='text/javascript' src='https://arizonasports.com/wp-content/plugins/tweak-events/assets/js/datepicker.js?ver=1.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var data = {"ajax_url":"https:\/\/arizonasports.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://arizonasports.com/wp-content/plugins/tweak-events/assets/js/event-submit-validate.js?ver=1.1'></script>
<script type='text/javascript' src='https://arizonasports.com/wp-content/plugins/tweak-events/assets/js/datepicker-submit.js?ver=1.0'></script>
<script type='text/javascript' src='https://arizonasports.com/wp-includes/js/wp-embed.min.js?ver=4.8.5'></script>
<!-- Sourcepoint --><script async="async" data-client-id="gbfrwGXjjAfkpzh" type="text/javascript" src="//d1xfq2052q7thw.cloudfront.net/2.0.1003.js"></script><!-- /Sourcepoint -->
<!-- Analytics -->
<!-- Google Analytics -->
<script>
  var _gaq = _gaq || [];
_gaq.push(['_setAccount', 'UA-333933-5']);
_gaq.push(['_setCustomVar',
    1,
    'Article"',
    'Sports',
    3
 ]);;
_gaq.push(['_setDomainName', 'arizonasports.com ']);
  _gaq.push(['_setPageGroup', 1, 'Arizona Cardinals Stories']);

  _gaq.push(['_trackPageview']);

  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://' : 'http://') + 'stats.g.doubleclick.net/dc.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();
</script>
<!-- End Google Analytics -->

<!-- Begin comScore Tag -->
<script>
  var _comscore = _comscore || [];
  _comscore.push({ c1: "2", c2: "16033947", c3: "", c4: "http://arizonasports.com/story/1442553/branch-brown-crack-nfl-coms-top-100-free-agent-list/?src=rss" });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>
<noscript>
  <img src="http://b.scorecardresearch.com/p?c1=2&c2=16033947&cv=2.0&cj=1" />
</noscript>
<!-- End comScore Tag -->
<!-- End Analytics -->

</body>
</html>
